Crash in nsWindow::GLControllerSupport::CreateEGLSurface when renewing EGL surface

RESOLVED FIXED in Firefox 46

Status

()

--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Ninu, Assigned: jchen)

Tracking

({crash})

Trunk
Firefox 46
crash
Points:
---

Firefox Tracking Flags

(firefox44 unaffected, firefox45 unaffected, firefox46 fixed)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-4b19bf37-7e9e-45ea-8727-83e0e2160108.
=============================================================

Build: Nightly 46.0a1 07-01-2016
Device: Xiaomi Mi i4 - Android 5.0.2 

Steps to reproduce:

1. Open Nightly build 
2. Visit Settings-General
3. Tap on "Full-screen browsing" button in order to activate/deactivate

Expected result
The app should not crash and the action should be performed

Actual result:
The app crashes but after a check, it can be noticed that the expected action (activation/deactivation of the full screen browsing) was performed.

Please note that this issue may be device specific since it could not be reproduced on a Samsung Galaxy S6 Edge with Android 5.1.1
Can you see any other crash information in logcat?
Flags: needinfo?(mihai.ninu)
(Reporter)

Comment 2

3 years ago
Created attachment 8705658 [details]
crash in EMPTY no crashing thread identified; ERROR_NO_THREAD_LIST LOGCAT.txt
Flags: needinfo?(mihai.ninu)
(Reporter)

Comment 3

3 years ago
Hi Mark,
Attached you will find a .txt file in which the logcat capturing the button tap action is caught and the result of it, hope it helps.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Duplicate of this bug: 1235755
Created attachment 8705749 [details] [diff] [review]
Fix crash when renewing EGL surface fails (v1)

We shouldn't crash when renewing an EGL surface fails, because the
compositor is able to handle it gracefully.
Attachment #8705749 - Flags: review?(snorp)
Duplicate of this bug: 1238485
Attachment #8705749 - Flags: review?(snorp) → review+
Summary: crash in EMPTY: no crashing thread identified; ERROR_NO_THREAD_LIST → Crash in nsWindow::GLControllerSupport::CreateEGLSurface when renewing EGL surface

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/29b1519577c5
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
You need to log in before you can comment on or make changes to this bug.