Closed Bug 1238029 Opened 4 years ago Closed 4 years ago

<input type="url"> allows invalid URL "http://" as valid data

Categories

(Core :: Layout: Form Controls, defect)

43 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1082441

People

(Reporter: jon.dufresne, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151229124331

Steps to reproduce:

* Create a form with input element <input type="url"> and a submit button
* In the URL input enter the invalid URL "http://" (without quotes)
* Submit the form


Actual results:

The form was accepted as valid data. However, the URL http:// is not a valid URL.

Firefox itself recognizes this as invalid if you try to enter that URL in the address bar.

If a web app uses the submitted value to create an anchor tag, a click on the link <a href="http://">text</a> will result in a page that reads "The address isn't valid".


Expected results:

The <input type="url"> should have been considered invalid. Especially considering that Firefox itself will later recognize this value as invalid.
Blocks: 344614
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Probably a duplicate of bug 1082441.
Depends on: 1082441
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1082441
You need to log in before you can comment on or make changes to this bug.