mozilla crashes when scrolling or filling in a form after downloading page with javascript error

VERIFIED WORKSFORME

Status

()

Core
Layout
P1
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Rein Smedinga, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
mozilla1.0
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

16 years ago
When clicking on a link resulting in downloading a page with sources as giving
in the attachment, both scrolling the page, or trying to fill in the form
results in a crash of Mozilla.

The javascript console gives the following error messages:

Error: document.getElementById("helptext").currentStyle has no properties
Source File: http://abba.eccoo.rug.nl/bambix/addcourse.php?edit=INFL.2001-2002.1
Line: 150

Error: document.getElementById("helptext").currentStyle has no properties
Source File: http://abba.eccoo.rug.nl/bambix/addcourse.php?edit=INGA
Line: 150

Error: redeclaration of const hide
Source File: chrome://wallet/content/walletOverlay.js
Line: 1

etc.

The messages above appear after downloading the page.
What happens during the crash has been captures by the talkback agent, see
the incidents with ID's  TB2572354Q and TB2571850K

Reproducable: always

URL: unfortunately, the urls are behind a password and used for local applications.
(Reporter)

Comment 1

16 years ago
Created attachment 68120 [details]
source of page that lets Mozilla crash
(Reporter)

Comment 2

16 years ago
Additional comment: I am using Build 2002020406.

Updated

16 years ago
Attachment #68120 - Attachment mime type: text/html → text/plain

Comment 3

16 years ago
Created attachment 68160 [details]
Rein's Talkback incidents

Comment 4

16 years ago
Created attachment 68162 [details]
Stack trace from a WinNT debug build

Comment 5

16 years ago
Confirming crash on Attachment #1 [details] [diff] above. All the stack traces look 
similar; based on them, reassigning to Layout component -
Assignee: rogerl → attinasi
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Layout
Ever confirmed: true
QA Contact: pschwartau → petersen
Taking bug. Marking nsbeta1+
Keywords: nsbeta1+
Target Milestone: --- → mozilla1.0

Updated

16 years ago
Priority: -- → P1

Updated

16 years ago
Whiteboard: creating testcase

Comment 7

16 years ago
Created attachment 69290 [details]
Reduced test that crashes (from original attachment)

Updated

16 years ago
Keywords: testcase
Whiteboard: creating testcase

Comment 8

16 years ago
Phil,

I reduced the test to a mininium number of functions in the script element (same
thing done with document's HTML elements). Could you take a look at the file ?

Comment 9

16 years ago
Chris: I was able to reduce the testcase even further and still get
the same stack trace as in Comment #4 above. Will attach this below -

Comment 10

16 years ago
Created attachment 69778 [details]
Reduced test even more (crashes with same stack as URL does)

Comment 11

16 years ago
To expand on my setup: using WinNT Mozilla trunk binary 2002021413
and a WinNT debug build 2002-02-10. 

I can't add any more from the JS Debugger, because the reduced test
crashes on load, before I can set a breakpoint. At any rate, the 
WinNT c++ stack trace in Comment #4 alwayss come up in any debug build
as soon as you load the test -

Comment 12

16 years ago
Here is the HTML source of the reduced test in Comment #10:

<html>
<head>
<title>Bug 123803</title>

<script>   
function onLoadActions()
{
  document.getElementById('cursusgegevens').style.display = 'none';           
  document.getElementById('periodeaanduiding').style.display = 'none';                
}
</script>
</head>

<body onload="onLoadActions()">

<div id='cursusgegevens'>
  <input id='periodeaanduiding'>
</div>

<input type='button'>

</body>
</html>

Comment 13

16 years ago
Note I get almost the same exact stack trace as in Comment #4 above
at http://software.xfx.net/uboards/indexp.php?forum=uboard_main.htm
when I mouseover the "DHTML Menu Builder" menu item at the top left.

Exact steps in http://bugzilla.mozilla.org/show_bug.cgi?id=125318#c9
One of the differences in the stack traces is the presence here of 
                     .
                     .  
          DeviceContextImpl::GetMetricsFor() line 303
          nsTextFrame::TextStyle::TextStyle() line 553
          nsTextFrame::Paint() line 1429


whereas at that site I get:
                     .
                     .
          DeviceContextImpl::GetMetricsFor() line 303
          ComputeLineHeight() line 2179 + 63 bytes
          nsHTMLReflowState::CalcLineHeight() line 2219


Will attach full stack trace below - 

Comment 14

16 years ago
Created attachment 70331 [details]
WinNT stack trace from http://software.xfx.net site

Comment 15

16 years ago
I'm not getting the crash with today's build on the test cases or url. If this 
is still crashing, please be specific on how to recreate it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

16 years ago
With 2002031104 no crashes any more so that problem seems to be fixed.

However, also no additonal texts and such appear after selecting the appropriate
radiobuttons and javascript console says:

Error: document.getElementById("helptext").currentStyle has no properties
Source File: http://abba.eccoo.rug.nl/bambix/forms/addcourse.php?edit=INPA99
Line: 62

I imagine this is because non-standard solutions are used in the script??
(It worked on previous versions of Mozilla)

Comment 17

16 years ago
Marking verfied wfm in the April 23rd OS X (2002-04-23-08) and Windows ME
(2002-04-23-06).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.