Make runserver Sign In links not working in Development Environment

RESOLVED FIXED

Status

Hello (Loop)
Client
P3
normal
Rank:
35
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: crafuse, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Error from console:

"[Exception... "NS_ERROR_CONNECTION_REFUSED"  nsresult: "0x804b000d (NS_ERROR_CONNECTION_REFUSED)"  location: "JS frame :: resource://services-common/rest.js :: onStopRequest :: line 465"  data: no]"

console:
Loop:hawkRequestInternal:  2 /fxa-oauth/params POST MozLoopService.jsm:600
Loop:Loop hawkRequest error: Object { error: Exception, errorString: "[Exception... "NS_ERROR_CONNECTION_…", message: null, code: null, errno: null, toString: toString() } MozLoopService.jsm:704
Loop:Object { error: Exception, errorString: "[Exception... "NS_ERROR_CONNECTION_…", message: null, code: null, errno: null, toString: toString() }

Debugged the sign with David, it seems the runfx and runserver does not allow connection to the sign-in site.

I can sign in when I make xpi and manually add the add-on and run loop-server does it work.

runserver seems to be blocking the connection to the resource.
(Reporter)

Updated

2 years ago
Whiteboard: [triage]
Mark Banner isn't about to reproduce.  Chris, can you give full steps to reproduce?
Flags: needinfo?(crafuse)
Whiteboard: [triage]
Rank: 35
(Reporter)

Comment 2

2 years ago
Can not reproduce again.  Must have been fixed in a recent patch.  This bug can be CLOSED.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(crafuse)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.