If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pink, green, and black flashes in H.264 YouTube video when using Apple's H.264 decoder

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P2
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

unspecified
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox42 affected, firefox43 affected, firefox44 affected, firefox45 affected, firefox46 affected)

Details

(URL)

(Assignee)

Description

2 years ago
STR:
1. Watch this YouTube video: https://www.youtube.com/watch?v=Kth0UOU5a_M&t=1m57s

RESULT:
At time 2:08, there are pink and green flashes. At time 2:12, there are black flashes.

These flashes are 100% reproducible in Firefox and Safari on OS X 10.11. The problem is not reproducible in Chrome, Firefox on Windows, or when watching VP9.
Should report that to apple. It's clearly their h264 decoder. 
cant do much about it.
I can reproduce this.
In both Firefox and Safari. We could work around by enabling vp9.

Assigning to Chris to follow up with Apple.
Assignee: nobody → cpeterson
Priority: -- → P2
(Assignee)

Comment 4

2 years ago
I am no longer able to reproduce these video flashes. I updated from OS X 10.11.1 to 10.11.2 yesterday, so perhaps this bug was fixed in 10.11.2.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: reproducible
OS: Unspecified → Mac OS X
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.