Closed Bug 1238222 Opened 6 years ago Closed 3 years ago

Intermittent font-display-1.html | image comparison (==), max difference: 255, number of differing pixels: 5997

Categories

(Core :: Layout: Text and Fonts, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox57 --- affected

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled])

Assignee: nobody → jdaggett
Argh, this is timing problem. For whatever reason it takes 12secs to load this page. The font loads too slowly, causing the font-display: fallback to load after the timeout expires. Not quite sure how to "solve" this problem but maybe it's best to just avoid this in the emulator case. Argh.
Assignee: jd.bugzilla → nobody
Duplicate of this bug: 1279825
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Looks like this has morphed into a new signature happening with regularity on Linux. Any chance you can take a look, Jonathan?
Flags: needinfo?(jfkthame)
I'm not sure there's anything really new here -- even 2 years ago, there's the occasional failure on Linux or Windows, among the majority-Android ones. The test is inherently troublesome, as it's trying to check delayed-fallback rendering behavior. So it's timing-dependent (as per comment 1), and anything that causes a font load to occasionally take longer than normal -- e.g. the browser is too busy cleaning up garbage from preceding tests, or some entirely unrelated process is hogging disk i/o, or whatever -- may result in a test failure.
Flags: needinfo?(jfkthame)
this seemed to have magically stopped on the 15th of September.
Whiteboard: [stockwell unknown]
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #52)
> this seemed to have magically stopped on the 15th of September.

That'll be because it was disabled in bug 1400386, at least for linux32.
Whiteboard: [stockwell unknown] → [stockwell disabled]
Depends on: 1403254
If it's a timing problem caused by the page being too slow to load, can't we increase the timeout for the test?
Flags: needinfo?(jfkthame)

In bug 1499124, we increased the font-loading delay values when running this test, which should make it much less likely we'll hit this kind of failure. Resolving as WFM, as it doesn't seem to be happening any more.

Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1499124
Flags: needinfo?(jfkthame)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.