mandelbrot demo stops rendering if I turn on SIMD

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox46 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160108030334

Steps to reproduce:

1. start fresh profile
2. go to http://peterjensen.github.io/mandelbrot/js/mandelbrot-ww-asm.html
3. Start the demo.  You can see the demo rendered.

Now turn on SIMD.



Actual results:

with simd turned on, the demo doesnt render.


Expected results:

not so
(Reporter)

Comment 1

2 years ago
Created attachment 8705944 [details]
aboutsupport.txt

Comment 2

2 years ago
¬°Hola!

I can reproduce this on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0 ID:20160108030334 CSet: 1424cdfc075d1b7e277be914488ac73e20d1c982

This is what the Browser Console shows FWIW:

Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. jquery-1.8.3.js:3255:28
TypeError: asm.js type error: bool32x4 is not a subtype of int32x4 mandelbrot-worker-asm.js:106:0
: Successfully compiled asm.js code (total compilation time 2ms; not stored in cache (too small to benefit)) mandelbrot-worker-asm.js

¬°Gracias!
Status: UNCONFIRMED → NEW
Has STR: --- → yes
status-firefox46: --- → affected
Ever confirmed: true

Comment 3

2 years ago
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1849d8dd63612df9b67712d81201d5cae09253c0&tochange=6d42293cc7917c59b2953de56a654a6a69d94867
Blocks: 1160971

Updated

2 years ago
Keywords: regression
Should be fixed by https://github.com/PeterJensen/mandelbrot/pull/13

Bug 1160971 made an incompatible change to the SIMD.js functions when catching up to the latest version of the spec.

Ben, was that pull request ok to merge?
Flags: needinfo?(bbouvier)
(In reply to Jakob Stoklund Olesen [:jolesen] from comment #4)
> Should be fixed by https://github.com/PeterJensen/mandelbrot/pull/13
> 
> Bug 1160971 made an incompatible change to the SIMD.js functions when
> catching up to the latest version of the spec.
> 
> Ben, was that pull request ok to merge?

Yes, thank you for the pull request, I just merged it, tested it and it compiles fine now.

Github doesn't send another email if there are commits added to a pull request, so I didn't see it was ready. Feel free to shout me an email or add a comment, next time :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bbouvier)
Resolution: --- → FIXED
Looks like this was fixed in 46 back in January.
status-firefox46: affected → fixed
You need to log in before you can comment on or make changes to this bug.