After clicking "pop Notification" button 10 times, the notification shows 10 time, it should be "9 new notifications"

RESOLVED DUPLICATE of bug 1219062

Status

()

Toolkit
Notifications and Alerts
--
enhancement
RESOLVED DUPLICATE of bug 1219062
2 years ago
2 years ago

People

(Reporter: ithompson4, Unassigned)

Tracking

({reproducible, uiwanted})

44 Branch
x86_64
Windows 7
reproducible, uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME][testday-20160108])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160107144911

Steps to reproduce:

Open https://pdehaan.github.io/push-notification-test/ and click pop Notification button.
Select "Always Show Notifications" from the notifications doorhanger. 
Click "pop Notification" button 10 times. 


Actual results:

 After clicking "pop Notification" button 10 times, the notification appears 10 times


Expected results:

Notification only appears once (and says ""9 new notifications"").
(Reporter)

Updated

2 years ago
Keywords: reproducible, testcase-wanted
OS: Unspecified → Windows 7
Priority: -- → P3
Hardware: Unspecified → x86_64
Whiteboard: [testday-20160108]
(Reporter)

Comment 1

2 years ago
Created attachment 8705952 [details]
notification appears 10 times.png

Forgot to include the screenshot

Updated

2 years ago
Severity: normal → enhancement
Component: Untriaged → Notifications and Alerts
Keywords: testcase-wanted → uiwanted
Priority: P3 → --
Product: Firefox → Toolkit
Summary: After clicking "pop Notification" button 10 times, the notification appears 10 time → After clicking "pop Notification" button 10 times, the notification shows 10 time, it should be "9 new notifications"
Whiteboard: [testday-20160108] → [DUPEME][testday-20160108]
Thanks so much for triaging this!

We don't currently support coalescing notifications on Windows or Linux. On OS X, we use the native Notification Center, which gives us that feature for free. I think we have some mock-ups for this on Windows, so it's definitely on our radar.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1219062
You need to log in before you can comment on or make changes to this bug.