Update from Firefox 43.0 to 43.0.4 created a corrupt mixture using 250MB HD space

RESOLVED DUPLICATE of bug 1201734

Status

()

RESOLVED DUPLICATE of bug 1201734
3 years ago
3 years ago

People

(Reporter: csmith, Unassigned)

Tracking

43 Branch
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

I updated to Firefox 43.0.4 from Firefox 43.0 with no error messages on my Gigabyte MA-790X based PC.


Actual results:

Firefox became unresponsive.
The normal CPU usage (On Ebay for example) was 40%.
After the update the usage was 98% to 100%.
During this excessive CPU usage, the memory usage steadily climbed.
I usually terminated Firefox when the memory usage was one Gigabyte above normal for Firefox, or I would wait longer, until the RAM usage reached 60% of installed RAM.
On closing Firefox, the program would sometimes crash and send a report to Mozilla.
I looked in Windows programs and features.
Both Firefox 43.0 and 43.0.4 were listed.
The program size of 43.0 was 163MB.
The program size of 43.0.4 was 88MB.
I deleted them and reloaded Firefox from scratch.
Firefox has now only 43.0.4 listed in Windows programs and features.
Firefox is now working normally.
I have the same phenomenon with Thunderbird.
Both version 38.4.0 and version 38.5.1 are listed in Windows programs and features.
I have no problems with Thunderbird, but I must find a way to back the data up.
I am afraid it will also crash or misbehave. 



Expected results:

Normal update.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86

Updated

3 years ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit
Thank you for the report. Unfortunately it won't be possible to do any investigation of the Firefox problems without being able to get a look at the actual installations. Since it sounds like you no longer have those, I'm afraid there isn't anything we can do about that. And for the Thunderbird case, we are already working on bug 1201734 for the problem of having two uninstall entries following an update (that bug is about Firefox, but the update code is the same).
Therefore, I'm resolving this bug by marking it a duplicate of bug 1201734, since the Thunderbird problem is the only part of your report that we can help with, and that bug already covers it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1201734
You need to log in before you can comment on or make changes to this bug.