Search keywords periodically lost

VERIFIED WORKSFORME

Status

()

defect
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: justdave, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox/45.0

Steps to reproduce:

1) click on the magnifying glass in the search box and pick "Manage Search Engines".
2) Add a keyword to a search engine.
3) Try using that search a few days later.

Actual results:

The keyword doesn't survive, and it's back to the defaults when you go look at the search engines after a few days. This has happened to me 3 or 4 times now in the last few weeks.  I haven't been able to find a pattern of when it disappears, it just does.  Is the search engine self-updating and when the engine itself updates it wipes out my custom keyword for it?
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #0)
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101
> Firefox/45.0
> 
> Steps to reproduce:
> 
> 1) click on the magnifying glass in the search box and pick "Manage Search
> Engines".
> 2) Add a keyword to a search engine.
> 3) Try using that search a few days later.
> 
> Actual results:
> 
> The keyword doesn't survive, and it's back to the defaults when you go look
> at the search engines after a few days. This has happened to me 3 or 4 times
> now in the last few weeks.  I haven't been able to find a pattern of when it
> disappears, it just does.

This seems vaguely similar to bug 1254694 (it would be interesting to confirm that if you customize the order of the search plugins, this order is lost at the same time as the keywords), but this bug can only occur while migrating from the old search-metadata.json file to the new search.json.mozlz4 file, while first starting Firefox 45.* on a profile created with an older Firefox version.

Do you somehow have a custom way to backup/restore your profile that could interfere?

> Is the search engine self-updating and when the
> engine itself updates it wipes out my custom keyword for it?

The search service support an update feature for search engines, although I don't know any example of an engine that uses this feature. If the problem happens only with one specific engine you installed yourself, I would be interested in having a look at this plugin.

And I realize this was filed several months ago, so it's possible it's just WFM at this point if you haven't seen this reoccur since you filed the bug.

Comment 2

3 years ago
Please re-open if you are still seeing this.  We are not reproducing the issue - and have been working in this area of the code.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Just to confirm, I haven't seen this in a while myself.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.