Extensions Do Not Install when Particular Pages Are Focused

RESOLVED DUPLICATE of bug 1171636

Status

()

RESOLVED DUPLICATE of bug 1171636
3 years ago
3 years ago

People

(Reporter: therubex, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Extensions Do Not Install when Particular Pages Are Focused - sometimes


URL: https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options
Extension: https://addons.mozilla.org/en-US/firefox/addon/offline-switch/
 
 
Load URL
Attempt (but do not complete) an install of a local (saved) extension
IOW attempt, & if prompted to install, dismiss the dialog (Cancel)

Attempt again
 
 
No indication of success or failure is given.
Extension fails to install.

Neither drag & drop nor Ctrl+O to attempt to load the extension works.

Sometimes, a page refresh, or a forced page refresh will bring up a "This site would like to install an add-on in Firefox".  (Might have to refresh/Ctrl+Shift+R a number of times.)
 
 
Extension should install.
What version of Firefox are you testing with?
Flags: needinfo?(therubex)
(Reporter)

Comment 2

3 years ago
It was FF 43 at the time.
But same issue with FF 44.

That said ...

I'm now seeing this hieroglyphic, sometimes, to the left of the globe (like thing) on the URL bar.

So...

Load URL
(URL may actually be irrelevant)

Ctrl+O
C:\my_extensions\offline_switch-0.6-fx.xpi

This site would like to install an addon in Firefox

ESC to cancel the dialog

Note that the hieroglyphic stays.
Turns out that that hieroglyphic is the install request for the extension - even though once you have ESC'd there really isn't anything there to tell you that you are still (somewhat) in an install mode.

Note that ESC'ing, or even changing focus from the window in question to some other window leaves you in a state different then had you actually clicked the Cancel button in the dialog.

That is none too obvious!

So what must have happened, is that I had either purposely hit ESC, taking that [in my mind] to mean /Cancel/, or focus changed I when I came back to the window, the install dialog no longer displayed, leading me to think that it "cancelled" itself.

With that thought in mind, my reaction is to drag the extension into the window (or Ctrl+O it) again.

Little did I realize that that hieroglyphic persisted, much less what it meant, much less that its persistence would taint subsequent attempts to install an extension.

So what does happen when that hieroglyphic persists.

You drag & drop (or Ctrl+O), & "nothing" seems to happen.
So you say, oh, I must have missed it?
Then you try again, with the same non-result.
Huh?
And again? And again?

And then you come here, & write a bug.

Only later to realize, ah, so that's what is happening.

Anyhow, after drag & drop'ing a number of times, without result, you might notice each time thereafter that you attempt, a little flicker in the page tab itself.

So say you attempt 9 times, & each time seemingly nothing happened, but, in fact something did (not that I'm exactly sure), but seems as if something got queued up.

Cause if you refresh the page - a number of times in succession, at some point, the install dialog will pop up.

Note that the dialog does not pop up from that hieroglyphic to the left of the URL, but rather it pops up from the tab area instead.  (In my case, as it just so happens with a number of tabs open, that means initially the dialog is [essentially] left-most, but when I finally get it to "reappear" it ended up being right-most [by the Bookmark icon & such]).

And note that at that point, (depending on the number of times that you unsuccessfully attempted the install, if seems) after refreshing the page a number of times & getting the dialog to display, if you hit the Cancel button, you most likely need to hit it repeatedly for the dialog to subside.

And again note that at that point hitting Cancel (multiple times if needed) rather then ESC'ing or changing focus & back, does... does what?

Is whatever got queued up actually "released" or is it still hanging about as "bloat", perhaps to release later, or not?

So... in the end, it might just be poor UX.
You might say unfamiliarity & hieroglyphic's may have contributed to the issue, but, regardless, it sure got me.

IMO, if you're going to put up a dialog, something that should be interacted with, it should not just "go away", even if it does happen to be hiding in an icon (that was otherwise unknown to me). It should force me to interact with it - Install or Cancel.  At least that way I know what the outcome should be.

And further, when I attempt the same action again, it should not silently just do nothing (as it sure seemed to me).  It should jump up in my face & say, "hey dummy, I'm sitting here waiting for you to complete your wanted operation!"

Hmm.  So that's what was going on.
At least now that I'm understanding what is happening & why, I will know for next time.
That said, I think the behavior is wrong.
Feel free to resolve this bug as you wish :-).
Flags: needinfo?(therubex)
This is basically tied up in the mess that is bug 1171636. I hear there are plans to fix that soon.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171636
You need to log in before you can comment on or make changes to this bug.