Fix the tab-start/-end gradient on XP, Vista and Windows 7 Classic/HC

RESOLVED FIXED in Thunderbird 46.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

({regression})

unspecified
Thunderbird 46.0
All
Windows
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird45+ fixed, thunderbird46 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

4 years ago
Posted image tabs_comparison.png
It seems I forgot in bug 1222805 also to change the tab SVG images. This makes a slight different gradient on normal Windows XP, Vista and 7 between the start/end parts and the middle part of the tabs. On High Contrast themes this difference is very good visible.

The screenshot shows it very good on a HC theme with the before and after patch comparison.
Assignee

Comment 1

4 years ago
For easier review see the screenshot in comment 0.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8706126 - Flags: review?(clokep)
Attachment #8706126 - Flags: review?(clokep) → review+
Assignee

Comment 2

4 years ago
http://hg.mozilla.org/comm-central/rev/59010ab63741
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 46.0
Assignee

Comment 3

4 years ago
Comment on attachment 8706126 [details] [diff] [review]
tabColor.patch

[Approval Request Comment]
Regression caused by (bug #): 1222805
User impact if declined: weird tab appearance on some Windows themes
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low, style change in SVG files
Attachment #8706126 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #8706126 - Flags: approval-comm-aurora? → approval-comm-aurora+

Updated

4 years ago
Duplicate of this bug: 1241853
You need to log in before you can comment on or make changes to this bug.