Private Tabs are not part of session restore (?)

RESOLVED WORKSFORME

Status

()

Firefox for Android
Session Restore
RESOLVED WORKSFORME
3 years ago
9 months ago

People

(Reporter: aaronmt, Unassigned)

Tracking

unspecified
All
Android
Points:
---

Firefox Tracking Flags

(fennec-)

Details

(Reporter)

Description

3 years ago
Platform differentiation here:

iOS - we restore private tabs (if you toggle the setting to restore tabs; why is that even off by default?!)

Android - we kill all your private tabs

On Android, why are we killing all of our private tabs?
(Reporter)

Comment 1

3 years ago
(In reply to Aaron Train [:aaronmt] from comment #0)
> Platform differentiation here:
> 
> iOS - we restore private tabs (if you toggle the setting to restore tabs;
> why is that even off by default?!)

Whoops, meant Android for that parenthesis comment
(Reporter)

Comment 2

3 years ago
re: pref switch, yay bug 1219343
tracking-fennec: --- → ?

Comment 3

3 years ago
We do have code to restore private tabs when we're OOM killed. Is that working? We should renom this if there's a bug with that logic.

We don't write your private tabs to disk, so there's no way for us to restore them unless Android gives us bundle with the tabs in them.

How is iOS doing this?
tracking-fennec: ? → -
Flags: needinfo?(sarentz)
(In reply to :Margaret Leibovic from comment #3)
> We do have code to restore private tabs when we're OOM killed. Is that
> working? We should renom this if there's a bug with that logic.
> 
> We don't write your private tabs to disk, so there's no way for us to
> restore them unless Android gives us bundle with the tabs in them.
> 
> How is iOS doing this?

Correct. Saving private tabs to disk violates the "private browsing" policy.
Flags: needinfo?(sarentz)
Seems to be working as designed:
1. Open a private tab and visit some URL.
2. Background Firefox.
3. |adb shell am kill <firefox package name>|
4. Look at "Running services" in Android's developer option's to verify that Firefox has indeed been killed.
5. Start Firefox again.
6. The private tab is restored.

If on the other hand Firefox has e.g. been killed by swiping away in the task switcher, then we don't get a saved data bundle from the OS and the private tabs aren't restored.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Component: General → Session Restore
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.