"AMO Browsing for SeaMonkey"-add-on: Exclude Language Packs (em:type="8") from converting

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
enhancement
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Rainer Bielefeld, Unassigned)

Tracking

(Blocks: 1 bug)

SeaMonkey 2.40 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently Language packs will be treated as quite normal extensions. For a test install the "AMO Browsing for SeaMonkey"-add-on from <https://github.com/lemon-juice/AMO-Browsing-for-SeaMonkey> and check some Language Packs like <https://addons.mozilla.org/en-US/seamonkey/addon/deutsch-de-language-pack-for-s/>, <https://addons.mozilla.org/en-US/thunderbird/addon/shqip-language-pack-thunderbir/>, <https://addons.mozilla.org/en-US/firefox/addon/norsk-bokm%C3%A5l-no-language-pa/>: The normal "You may try using the Add-on Converter to increase ..." message will be added by add-on-converter-add-on.

But I doubt that that can work.

a) SeaMonkey-Language-Packs:
My experience is that each SeaMonkey Version needs it's particular Language pack. Using a language pack from a different version will cause error messages and serious problems, see "Bug 1084258 - Language pack compatibility should be bound to Gecko branch, else undefined entity errors possible" and it's DUPs

b) TB and FF language packs
TB and FF have completely different UI, so I doubt that a Language Pack from those applications can work with SeaMonkey.

c) So Language Packs should not show the message what suggests to 
   convert.
(Reporter)

Comment 1

2 years ago
NEW due to <https://blog.seamonkey-project.org/2015/11/25/my-unconfirmed-bug-reports/>
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "AMO Browsing for SeaMonkey"-add-on: Exclude Language Packs from converting → "AMO Browsing for SeaMonkey"-add-on: Exclude Language Packs (em:type="8") from converting

Comment 3

2 years ago
The question is how to detect a language pack? I believe standard dictionaries can be detected because they contain code to get them to appear in the dictionaries section of the addons manager. But many language packs install like normal extensions and it's hard to programmatically detect them.

Even if I was able to do it I can only do it on the converter page and show a big red warning for language packs. But this won't be possible on the AMO page because the AMO browsing extension does not parse the source code of extensions (it would be very difficult, anyway). So I can't really see a solution apart from adding a warning that language packs should not be converted. Maybe someone has other ideas?
(Reporter)

Comment 4

2 years ago
(In reply to lemon_juice from comment #3)
> But this won't be possible on the AMO page because the AMO browsing extension 
> does not parse the source code of extensions

You are right, a better place to reach the goal of this report would be the converter page itself. During conversion install.rdf can be checked, and if "type="8"" has been detected, the converter should not deliver a converted add-on, but show a warning "Language Pack detected, must not be converted"

I think we should close this report and submit a new enhancement request for converter.

Comment 5

2 years ago
I've added a warning that is displayed by the converter when converting a language pack - even if the direct install button is pressed. See if this works as intended.
(Reporter)

Comment 6

2 years ago
Created attachment 8732623 [details]
New Warning
(Reporter)

Comment 7

2 years ago
I tested with <https://addons.mozilla.org/en-US/firefox/addon/%D8%A7%D9%84%D8%B9%D8%B1%D8%A8%D9%8A%D8%A9-language-pack/>: New obvious warning appears after conversion.

So WFM
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.