Closed Bug 1238499 Opened 9 years ago Closed 1 year ago

Discrepancy between enabled and disabled e10s, different number of options to be displayed

Categories

(Core :: Layout: Form Controls, defect)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
e10s - ---

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1238488 +++


Steps to reproduce:
1. Open http://codepen.io/cgarnier/pen/zrzqaM

Actual results:
If enabled e10s, there are 23 options
If disabled e10s, only 1 option

Expected results:
Same as Chrome, Edge and IE11 ,there are 23 options.
OR
At least, it should be no discrepancy between enabled and disabled e10s.
A plain html file attached here would be great.
Attached file testcase
Blocks: core-e10s
Keywords: testcase
Whiteboard: [parity-IE] [parity-Chrome][parity-Edge]
This one is easy to explain, I guess.
In non-e10s mode <option>s in testcase are aligned horizontally because of "display: inline-block;"
In e10s mode it's not possible to style <option>s (right?). So they align vertically.
I'll mark it as dependant bug for now; feel free to edit.
Depends on: 910022
In addition (if you also noticed the difference between Nightly and Release):

On Release 43 I see a very long drop-down list with only 1 option (that is expected, because <option>s have "display: inline-block;"), while on Nightly 46 (non-e10s mode) the drop-down list's height equals to the <option>'s height.
That part was fixed by bug 1208978. Fix range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=36cd98d7f222d2e4177dc43eb55e0b1f655b55dd&tochange=67f016207ddeab47ac1341873e6d3c1be389f0f5
Severity: normal → S3

Are you still able to reproduce this bug?

Flags: needinfo?(alice0775)

No, no longer available non-e10s.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(alice0775)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: