Consider replacing the last use of usingDisplayPort in ScrollFrameHelper::BuildDisplayList with mWillBuildScrollableLayer

RESOLVED DUPLICATE of bug 1405397

Status

()

RESOLVED DUPLICATE of bug 1405397
3 years ago
a year ago

People

(Reporter: mstange, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Reporter)

Description

3 years ago
There's only one use of usingDisplayPort left in ScrollFrameHelper::BuildDisplayList:

https://dxr.mozilla.org/mozilla-central/rev/6020a4cb41a77a09484c24a5875bb221714c0e6a/layout/generic/nsGfxScrollFrame.cpp#2974 :
> // If we are a root scroll frame that has a display port we want to add
> // scrollbars, they will be children of the scrollable layer, but they get
> // adjusted by the APZC automatically.
> bool addScrollBars = mIsRoot && usingDisplayPort && !aBuilder->IsForEventDelivery();

I don't really understand what this condition wants to achieve. Why not add scrollbars always? I suppose we don't want them to swallow touch events on B2G/Android, but I don't understand the rest of the conditions.
(Reporter)

Updated

3 years ago
Flags: needinfo?(tnikkel)
We did this in bug 1405397. https://hg.mozilla.org/mozilla-central/rev/d6fdc1d3b070
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tnikkel)
Resolution: --- → DUPLICATE
Duplicate of bug: 1405397
You need to log in before you can comment on or make changes to this bug.