Page layout redrawn but does not keep focus on current content on the screen

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
8 months ago

People

(Reporter: djbarney, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Android 4.4.2; Tablet; rv:43.0) Gecko/43.0 Firefox/43.0
Build ID: 20151214163750

Steps to reproduce:

Viewed a page for which not all content has known sizes.


Actual results:

A number of times a website has been loading and I've been reading content. The browser retrieves an image or content for which the size was not known before full retrieval. The browser then redraws the page which often has the result of moving the text in my focus. This often leads to constantly having to scroll back to the text often multiple times. Sometimes touching on a link can lead to following the wrong link due to the page redraw bringing up a different link in those few milliseconds. It would be nice if the browser could attempt to keep currently displayed content on the screen rather than just blindly adding to the page and ignoring the effect on currently viewed content.


Expected results:

Text and other media currently scrolled to by the user should stay on the screen or at least nearby.
Hello Djbarney,

I couldn't reproduce this issue following the steps from the description on the latest Nightly build with a Samsung Galaxy S8+ (Android 8.0.0), Prestigio MultiPhone 5508 Android 4.4.2 following this test case:
1.Access any of the following: www.betfair.ro / www.popuptest.com / www.cnn.com.
2.Wait for the page content to load.
3.Tap on any pop-up or link from the loaded pages.

I will close this issue as worksforme based on my comment, if this is still reproducing for you, please re-open it and mention what device, build and web sites you used.

Thanks,
Andrei
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.