[traceback] AttributeError: 'NoneType' object has no attribute '_info'

VERIFIED DUPLICATE of bug 1234711

Status

support.mozilla.org
Localization
VERIFIED DUPLICATE of bug 1234711
2 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
STR:

Load https://support.mozilla.org/gu-IN/localization

Actual:

exceptions:AttributeError /kitsune.dashboards.views:localization

exceptions:AttributeError: 'NoneType' object has no attribute '_info' 


Stack trace
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/newrelic-2.44.0.36/newrelic/hooks/framework_django.py", line 497, in wrapper return wrapped(*args, **kwargs)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/views/decorators/http.py", line 41, in inner return func(request, *args, **kwargs)
File "/data/www/support.mozilla.org/kitsune/kitsune/dashboards/views.py", line 111, in localization extra_data=data, product=product)
File "/data/www/support.mozilla.org/kitsune/kitsune/dashboards/utils.py", line 78, in render_readouts return render(request, 'dashboards/' + template, data)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/shortcuts.py", line 50, in render return HttpResponse(loader.render_to_string(*args, **kwargs),
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/template/loader.py", line 178, in render_to_string return t.render(context_instance)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/jingo/__init__.py", line 98, in render return super(Template, self).render(context_dict)
File "/usr/lib64/python2.6/site-packages/newrelic-2.44.0.36/newrelic/api/function_trace.py", line 98, in dynamic_wrapper return wrapped(*args, **kwargs)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/jinja2/environment.py", line 891, in render return self.environment.handle_exception(exc_info, True)
File "/data/www/support.mozilla.org/kitsune/kitsune/dashboards/templates/dashboards/localization.html", line 8, in top-level template code {% set classes = 'localization-dashboard' %}
File "/data/www/support.mozilla.org/kitsune/kitsune/sumo/templates/base.html", line 187, in top-level template code {% block content %}{% endblock %}
File "/data/www/support.mozilla.org/kitsune/kitsune/dashboards/templates/dashboards/localization.html", line 20, in block "content" {{ a.content|wiki_to_html }}
File "/data/www/support.mozilla.org/kitsune/kitsune/sumo/helpers.py", line 110, in wiki_to_html nofollow=nofollow))
File "/data/www/support.mozilla.org/kitsune/kitsune/sumo/parser.py", line 49, in wiki_to_html nofollow=nofollow)
File "/data/www/support.mozilla.org/kitsune/kitsune/sumo/parser.py", line 247, in parse html = _parse(locale)
File "/data/www/support.mozilla.org/kitsune/kitsune/sumo/email_utils.py", line 46, in wrapper return f(locale, *args, **kwargs)
File "/usr/lib64/python2.7/contextlib.py", line 24, in __exit__ self.gen.next()
File "/data/www/support.mozilla.org/kitsune/kitsune/sumo/utils.py", line 215, in uselocale translation.activate(currlocale)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/utils/translation/__init__.py", line 145, in activate return _trans.activate(language)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/utils/translation/trans_real.py", line 225, in activate _active.value = translation(language)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/utils/translation/trans_real.py", line 210, in translation current_translation = _fetch(language, fallback=default_translation)
File "/data/www/support.mozilla.org/kitsune/virtualenv/lib/python2.7/site-packages/django/utils/translation/trans_real.py", line 173, in _fetch res._info = res._info.copy()
AttributeError: 'NoneType' object has no attribute '_info'

New Relic: https://rpm.newrelic.com/accounts/263620/applications/2779374/traced_errors/2a695c-9c574e97-b8aa-11e5-8436-c81f66b8ceca?original_error_id=2a6967-5e22bc50-b8aa-11e5-8436-c81f66b8ceca

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1234711
(Reporter)

Comment 2

2 years ago
Apologies for the dupe :-(

Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.