Correct fonts are not used when printing from the PDF Viewer on a Mac

RESOLVED DUPLICATE of bug 1108922

Status

()

RESOLVED DUPLICATE of bug 1108922
3 years ago
3 years ago

People

(Reporter: cking, Unassigned)

Tracking

43 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8706618 [details]
01 Basic Lab Skills.pdf, which used substituted fonts when printed on a Mac.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

A Microsoft Word file was converted to a .pdf, and put on the web.  The file looks correct in the PDF Viewer on both Windows and a Mac.  The file prints correctly on Windows, but on printing on the Mac, the fonts got changed.  On the Mac, the file was then downloaded and printed from Adobe Reader, with the result that it looked fine when printed.  The file is attached.  The Mac had Microsoft Word installed, so that computer should have had the necessary fonts to print the document.  Also, According to Adobe Reader, all but the font "Arial" are embedded in the document.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X

Updated

3 years ago
Component: Untriaged → Printing: Output
Product: Firefox → Core

Comment 1

3 years ago
Is it possible to scan the print output (as PDF) and attach it to the bug?
Flags: needinfo?(cking)
(Reporter)

Comment 2

3 years ago
Created attachment 8707504 [details]
Page 1, printed with correct fonts

I was asked for a scanned copy demonstrating the problem.  The first time my friend (who has the Mac computer) printed this page, it printed correctly, so this problem is not reproducible.
Flags: needinfo?(cking)
(Reporter)

Comment 3

3 years ago
Created attachment 8707507 [details]
Page 1, printed with wrong fonts

My friend then printed that page a second time.  This time, it did not use the correct fonts.

Comment 4

3 years ago
I know this bug and it's a dupe. I guess it's reproducible every time if you open the PDF and browse another tab during 30 sec and you go back to the PDF tab to print it.
It's because FF "removes" the rendering of background tab from memory. If the user scrolls the PDF before printing to update the rendering, the print output will be fine.

Comment 5

3 years ago
Found it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108922
You need to log in before you can comment on or make changes to this bug.