Closed Bug 1238769 Opened 5 years ago Closed 5 years ago

Add a -xpcshell option to Firefox

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 47
Tracking Status
firefox46 --- affected
firefox47 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file, 1 obsolete file)

Now that xpcshell is just a (literal) shell around XRE_XPCShellMain, we can actually just make Firefox itself work as the xpcshell.
Attachment #8706654 - Flags: review?(benjamin)
Attachment #8706654 - Flags: review?(benjamin) → review+
Big facepalm on my part. Trivial change to make it build on all platforms.
Attachment #8706654 - Attachment is obsolete: true
Attachment #8715823 - Flags: review?(benjamin)
See Also: → 1245914
Attachment #8715823 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/f5c043dfcb47
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
So is this supposed to do something now?

firefox -xpcshell toolkit/components/autocomplete/tests/unit/test_finalCompleteValue_forceComplete.js

It just produces no output and finishes.
Flags: needinfo?(mh+mozilla)
(In reply to Magnus Melin from comment #7)
> So is this supposed to do something now?
> 
> firefox -xpcshell
> toolkit/components/autocomplete/tests/unit/
> test_finalCompleteValue_forceComplete.js
> 
> It just produces no output and finishes.

It works for me on Linux, but I can reproduce on Windows. Unfortunately, I can't tell why it does that. Following with a debugger says it exists through https://dxr.mozilla.org/mozilla-central/rev/ae7413abfa4d3954a6a4ce7c1613a7100f367f9a/js/xpconnect/src/XPCShellImpl.cpp#1593
Bobby, any ideas? (this should probably be filed as a separate bug)
Flags: needinfo?(mh+mozilla) → needinfo?(bobbyholley)
FWIW, I was testing on linux (though with a nightly, not a local build).
(In reply to Mike Hommey [:glandium] from comment #8)
> (In reply to Magnus Melin from comment #7)
> > So is this supposed to do something now?
> > 
> > firefox -xpcshell
> > toolkit/components/autocomplete/tests/unit/
> > test_finalCompleteValue_forceComplete.js
> > 
> > It just produces no output and finishes.
> 
> It works for me on Linux, but I can reproduce on Windows. Unfortunately, I
> can't tell why it does that. Following with a debugger says it exists
> through
> https://dxr.mozilla.org/mozilla-central/rev/
> ae7413abfa4d3954a6a4ce7c1613a7100f367f9a/js/xpconnect/src/XPCShellImpl.
> cpp#1593
> Bobby, any ideas? (this should probably be filed as a separate bug)

That must means that something in ProcessArgs threw an exception or otherwise caused us to return false. You'll need to step into that function to get to the source.
Flags: needinfo?(bobbyholley)
You need to log in before you can comment on or make changes to this bug.