If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WebGL broken with D3D9 ANGLE backend in Nightly

RESOLVED FIXED

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Luke, Unassigned)

Tracking

Trunk
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
Steps to reproduce:
1. about:config
2. webgl.angle.try-d3d11 -> FALSE
3. http://get.webgl.org/

Expected Results:
See a rotating 3D object

Actual Results:
FF 43.x -> Correct
FF 46.0a1 (2016-01-11) -> Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.


I noticed this issue with both my laptop w/ Intel HD 4000 and desktop w/ Nvidia 650 GTX. 

This important to fix because older hardware like my laptop w/ X1300 do not support D3D11.
Whiteboard: [gfx-noted]
(Reporter)

Comment 1

2 years ago
WebGL is now working again on Nightly. Thank you.

Tested on 47.0a1 (2016-02-03)
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.