[fling-player][TV][2.5] Display confirm dialog and kill fling app if user confirm close

VERIFIED FIXED in Firefox OS v2.5

Status

Firefox OS
Gaia::TV::Fling
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: josh, Assigned: Fischer)

Tracking

(Blocks: 2 bugs)

unspecified
2.6 S6 - 1/29
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
(Only in 2.5)
When user press back key, we need to display a confirmation dialog and call 
window.close() to kill itself.
(Reporter)

Comment 1

2 years ago
Hi Fischer,
Please help this. Thanks.
Assignee: nobody → fliu
blocking-b2g: --- → 2.5+
Flags: needinfo?(fliu)
(Reporter)

Updated

2 years ago
No longer blocks: 1199525
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1223287
(Reporter)

Comment 3

2 years ago
Please use "Do you want to end video playback?" string for user confirmation dialog.
Comment hidden (typo)
QA Whiteboard: [COM=TV Seamless Experience]
Comment hidden (obsolete)
Comment hidden (obsolete)
(Assignee)

Comment 7

2 years ago
@Josh,
Just double check that only for v2.5 or for v2.5 + master, thank you
Flags: needinfo?(jocheng)
(Reporter)

Comment 8

2 years ago
Correct to my description 0. This approach is for 2.5 only. After 2.5 we will consider handle back key overally in system.
(Reporter)

Updated

2 years ago
Flags: needinfo?(jocheng)
(Reporter)

Comment 9

2 years ago
(In reply to [:Fischer]Fischer from comment #7)
> @Josh,
> Just double check that only for v2.5 or for v2.5 + master, thank you

We need this both master and 2.5. Thanks
(Assignee)

Updated

2 years ago
Flags: needinfo?(fliu)

Updated

2 years ago
Blocks: 1239346
(Assignee)

Comment 10

2 years ago
Created attachment 8708251 [details]
test_confirm_to_end_fling-player_on_tv_by_back_key.png

Comment 11

2 years ago
Created attachment 8708260 [details] [review]
[gaia] Fischer-L:bug_1238817-back-key-to-kill-fling-player > mozilla-b2g:master
(Assignee)

Comment 12

2 years ago
Comment on attachment 8708260 [details] [review]
[gaia] Fischer-L:bug_1238817-back-key-to-kill-fling-player > mozilla-b2g:master

@Rex,
This patch would ask user's confirmation to end fling player on back key pressed.
Please see test_confirm_to_end_fling-player_on_tv_by_back_key.png attached.
That is the test on a real TV, thank you.
Attachment #8708260 - Flags: review?(rexboy)
Comment on attachment 8708260 [details] [review]
[gaia] Fischer-L:bug_1238817-back-key-to-kill-fling-player > mozilla-b2g:master

Looks good to me!
Attachment #8708260 - Flags: review?(rexboy) → review+
(Assignee)

Comment 14

2 years ago
Land to Master: https://github.com/mozilla-b2g/gaia/commit/e7571bfbd2230e34c4220b4be782c8db113acf89
Test: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=3e8322a12f302c1f4138523822324158cd649dbb
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

2 years ago
Comment on attachment 8708260 [details] [review]
[gaia] Fischer-L:bug_1238817-back-key-to-kill-fling-player > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1238817
[User impact] if declined: Unable to leave fling player by pressing Back key
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: Yes
Attachment #8708260 - Flags: approval-gaia-v2.5?(jocheng)
(Reporter)

Comment 16

2 years ago
Comment on attachment 8708260 [details] [review]
[gaia] Fischer-L:bug_1238817-back-key-to-kill-fling-player > mozilla-b2g:master

Approve for TV 2.5
Attachment #8708260 - Flags: approval-gaia-v2.5?(jocheng) → approval-gaia-v2.5+
https://github.com/mozilla-b2g/gaia/commit/9a98e5f34d3e7e07c121d9e888b9711d6612f3a4
status-b2g-v2.5: --- → fixed
(Assignee)

Updated

2 years ago
Depends on: 1241366
(Assignee)

Updated

2 years ago
No longer depends on: 1241366
Verify:

========= Master: Passed ===================
gaia:
https://github.com/mozilla-b2g/gaia/commit/77c0e08caa0dda8c6e50f6e7cbad9f79b320a3b0
gecko:
https://hg.mozilla.org/mozilla-central/rev/a1b94785b48437662c696c9143ed92639e9617b2

========= v2.5: Passed ===================
gaia:
https://github.com/mozilla-b2g/gaia/commit/8a0d9deb2cd47df25750ed2c6820909e4feac3bb
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae919160ce8c6a6e9c6d86017b02e1345dea382d
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae919160ce8c6a6e9c6d86017b02e1345dea382d
Status: RESOLVED → VERIFIED
status-b2g-v2.5: fixed → verified
status-b2g-master: --- → verified
You need to log in before you can comment on or make changes to this bug.