If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add deprecation/shutdown notice on https://developer.mozilla.org/en-US/Persona

RESOLVED FIXED

Status

Developer Documentation
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rfkelly, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

2 years ago
There's an MDN portal for Persona at https://developer.mozilla.org/en-US/Persona; Now that we've announced plans to decommission the service, we should update it to mention the shutdown and steer users to the info on alternatives.
(Reporter)

Comment 1

2 years ago
:sheppy, you're my go-to expert on tech docs matters - any chance you can advise on what would be a good course of action for the Persona MDN portal now that we've announced we're shutting it down?  Just deleting all the docs seems like it could be a bit extreme, but maybe we can add a notice to the top of all the pages linked to the shutdown info?
Flags: needinfo?(eshepherd)
Component: Server: Identity → General
Product: Cloud Services → Developer Documentation
(In reply to Ryan Kelly [:rfkelly] from comment #1)
> :sheppy, you're my go-to expert on tech docs matters - any chance you can
> advise on what would be a good course of action for the Persona MDN portal
> now that we've announced we're shutting it down?  Just deleting all the docs
> seems like it could be a bit extreme, but maybe we can add a notice to the
> top of all the pages linked to the shutdown info?

I think we should:
* add a notice now
* when decommissioning happens, archive the docs (https://developer.mozilla.org/en-US/docs/Archive)

I think we should not delete them, as they might be useful for someone trying to build something similar.
How does this look?

https://developer.mozilla.org/en-US/Persona

If it looks all right, I'll add it to add the Persona pages.
Flags: needinfo?(rfkelly)
Duplicate of this bug: 1238893
Flags: needinfo?(eshepherd)
(Reporter)

Comment 5

2 years ago
Looks great!  Thanks again for jumping on to this so quickly.
Flags: needinfo?(rfkelly)
OK, I've added this notice to all pages under https://developer.mozilla.org/en-US/Persona.

I've used a macro: https://developer.mozilla.org/en-US/docs/Template:PersonaDecommissioningNotice, so we can easily tweak the wording if we need to.

I'm closing this now, but please let me know of you need anything else.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.