[TV][2.5]Listen to Backspace not esc key for back function

VERIFIED FIXED

Status

Firefox OS
Gaia::TV
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: josh, Assigned: rickychien)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker])

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

2 years ago
Back function should listen to "Backspace" key not "Esc" key.
(Reporter)

Comment 1

2 years ago
@Dan,
Please also help to update MDN about key mapping.
Thanks
Blocks: 1214243
blocking-b2g: --- → 2.5+
Flags: needinfo?(dhuang)
Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker]
(Reporter)

Updated

2 years ago
Assignee: nobody → rchien
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 2

2 years ago
Hi David,
Please aware about the change and notify 3rd developers afterward. This is to align current partner implementation.
Flags: needinfo?(dwalsh)
Created attachment 8706820 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master
(Assignee)

Comment 4

2 years ago
Comment on attachment 8706820 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master

Luke, here is a simple patch for replacing ESC with Backspace.
Attachment #8706820 - Flags: review?(lchang)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED

Comment 6

2 years ago
This change will effect 2.5+ on TV, correct?
(Assignee)

Comment 7

2 years ago
(In reply to Michael Ellis from comment #6)
> This change will effect 2.5+ on TV, correct?

yes

Comment 8

2 years ago
Comment on attachment 8706820 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master

R+ with comments on GitHub. Please take a look. BTW, you may need to modify the corresponding smart components as well.
Attachment #8706820 - Flags: review?(lchang) → review+
Created attachment 8707737 [details] [review]
[gaia] mozilla-b2g:revert-33838-backspaceToBack > mozilla-b2g:master
Created attachment 8707738 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master
Thank you Luke, follow up patches for corresponding smart-components are being filed.

Landed in master:

https://github.com/mozilla-b2g/gaia/commit/2d6c11a1e82bd9f9b7491863c8d1ea4a14aea69f

Landed in smart-dialog

https://github.com/smart-components/smart-dialog/commit/a18be5a9eea166ca91da7fb114fce7f98ff21e08
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8707738 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master

Previous patch has been reverted since I forgot to sync all modified comments in smart-dialog.

New patch fixes these forgotten comments and have re-landed in master.
Comment on attachment 8707738 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1214243
[User impact] if declined: unable to align partner's physical remote controller implementation
[Testing completed]: manual verified / tested on local
[Risk to taking this patch] (and alternatives if risky): minor
[String changes made]: n/a
Attachment #8707738 - Flags: approval-gaia-v2.5?
(Reporter)

Comment 14

2 years ago
Comment on attachment 8707738 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master

Approve for TV 2.5
Attachment #8707738 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(Assignee)

Updated

2 years ago
Attachment #8707738 - Flags: approval-gaia-v2.5+
Created attachment 8708166 [details] [review]
[gaia] mozilla-b2g:revert-33864-backspaceToBack > mozilla-b2g:master
Revert https://github.com/mozilla-b2g/gaia/commit/e59727554e22f0290400959c0a2d26a7cac68f11

Due to backspace affecting normal keyboard delete behavior so we decided to back this out.
I'll not contact partners now.
Flags: needinfo?(dwalsh)
(Assignee)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
As our offline discussion, let's try to detect the current status of keyboard app before handling "backspace" key in system app.
(Assignee)

Updated

2 years ago
Blocks: 1235300
Created attachment 8712488 [details] [review]
[gaia] rickychien:esc-backspace > mozilla-b2g:master
Comment on attachment 8706820 [details] [review]
[gaia] rickychien:backspaceToBack > mozilla-b2g:master

>https://github.com/mozilla-b2g/gaia/pull/33838
Attachment #8706820 - Attachment is obsolete: true
Comment on attachment 8707737 [details] [review]
[gaia] mozilla-b2g:revert-33838-backspaceToBack > mozilla-b2g:master

>https://github.com/mozilla-b2g/gaia/pull/33863
Attachment #8707737 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8708166 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8712488 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8707738 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8712488 - Attachment is obsolete: false
Comment on attachment 8712488 [details] [review]
[gaia] rickychien:esc-backspace > mozilla-b2g:master

I knew we're waiting for this a few days ago.
Attachment #8712488 - Flags: review?(lchang)
(Reporter)

Updated

2 years ago
Priority: -- → P1
(Assignee)

Updated

2 years ago
Blocks: 1242870
(Assignee)

Updated

2 years ago
Blocks: 1242361
(Reporter)

Comment 23

2 years ago
Hi Ricky,
Could this been fixed by Jan 29?
Flags: needinfo?(rchien)
I believe I can.
Flags: needinfo?(rchien)
Comment on attachment 8712488 [details] [review]
[gaia] rickychien:esc-backspace > mozilla-b2g:master

Nice work!
Attachment #8712488 - Flags: review?(lchang) → review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/c5dec163d4b33c56d7491f00be69c0a9ff471a7d
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Comment on attachment 8712488 [details] [review]
[gaia] rickychien:esc-backspace > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1214243
[User impact] if declined: unable to align partner's physical remote controller implementation
[Testing completed]: manual verified / tested on local
[Risk to taking this patch] (and alternatives if risky): minor
[String changes made]: N/A
Attachment #8712488 - Flags: approval-gaia-v2.5?
(Reporter)

Comment 28

2 years ago
Comment on attachment 8712488 [details] [review]
[gaia] rickychien:esc-backspace > mozilla-b2g:master

Approved for TV 2.5
Attachment #8712488 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(Assignee)

Updated

2 years ago
Blocks: 1242359
(Reporter)

Updated

2 years ago
status-b2g-master: affected → fixed

Comment 31

2 years ago
This issue is verified on v2.5 and v2.6 latest build.
Backspace key works instead of ESC key now and it will detect the current status of keyboard app before handling "backspace" key in system app.

[Build Info]
2.6 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/5b90c09648798d8d66c4b08f81402b27acf0dc08
gecko:
https://hg.mozilla.org/mozilla-central/rev/05c087337043dd8e71cc27bdb5b9d55fd00aaa26

2.5 TV Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/81460a1025c357ca8a52e5bc8647fff6bb005638
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/240426e9718eab5661517e3f9ad6173819284615
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3
Status: RESOLVED → VERIFIED

Updated

2 years ago
status-b2g-v2.5: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.