crash in java.lang.OutOfMemoryError: (Heap Size=183996KB, Allocated=111918KB) at java.util.ArrayList.add(ArrayList.java)

RESOLVED DUPLICATE of bug 1240500

Status

()

--
critical
RESOLVED DUPLICATE of bug 1240500
3 years ago
3 years ago

People

(Reporter: Usul, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Android
crash
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-4da4602d-1de1-4ff7-a6d4-9223e2160112.
=============================================================
java.lang.OutOfMemoryError: (Heap Size=183996KB, Allocated=111918KB)
	at java.util.ArrayList.add(ArrayList.java:118)
	at org.mozilla.gecko.home.SearchEngineRow.bindSuggestionView(SearchEngineRow.java:275)
	at org.mozilla.gecko.home.SearchEngineRow.updateFromSavedSearches(SearchEngineRow.java:314)
	at org.mozilla.gecko.home.SearchEngineRow.updateSuggestions(SearchEngineRow.java:403)
	at org.mozilla.gecko.home.BrowserSearch$SearchAdapter.bindView(BrowserSearch.java:1103)
	at org.mozilla.gecko.home.MultiTypeCursorAdapter.getView(MultiTypeCursorAdapter.java:62)
	at android.widget.AbsListView.obtainView(AbsListView.java:2450)
	at android.widget.ListView.makeAndAddView(ListView.java:1891)
	at android.widget.ListView.fillSpecific(ListView.java:1438)
	at android.widget.ListView.layoutChildren(ListView.java:1709)
	at android.widget.AbsListView.onLayout(AbsListView.java:2275)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1671)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1525)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1434)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.FrameLayout.layoutChildren(FrameLayout.java:453)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:388)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.RelativeLayout.onLayout(RelativeLayout.java:1055)
	at org.mozilla.gecko.GeckoApp$MainLayout.onLayout(GeckoApp.java:2610)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.RelativeLayout.onLayout(RelativeLayout.java:1055)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.FrameLayout.layoutChildren(FrameLayout.java:453)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:388)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1671)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1525)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1434)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.widget.FrameLayout.layoutChildren(FrameLayout.java:453)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:388)
	at android.view.View.layout(View.java:14963)
	at android.view.ViewGroup.layout(ViewGroup.java:4656)
	at android.view.ViewRootImpl.performLayout(ViewRootImpl.java:2148)
	at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1860)
	at android.view.ViewRootImpl.doTraversal(ViewRootImpl.java:1076)
	at android.view.ViewRootImpl$TraversalRunnable.run(ViewRootImpl.java:5913)
	at android.view.Choreographer$CallbackRecord.run(Choreographer.java:807)
	at android.view.Choreographer.doCallbacks(Choreographer.java:601)
	at android.view.Choreographer.doFrame(Choreographer.java:562)
	at android.view.Choreographer$FrameDisplayEventReceiver.run(Choreographer.java:791)
	at android.os.Handler.handleCallback(Handler.java:733)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:157)
	at android.app.ActivityThread.main(ActivityThread.java:5867)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:858)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:674)
	at dalvik.system.NativeStart.main(Native Method)



0 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	widget/android/AndroidJNI.cpp
Ø 1 	libdvm.so 	libdvm.so@0x20a0e 	
Ø 2 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x4414e1 	
Ø 3 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x3f036 	
Ø 4 	dalvik-zygote (deleted) 	dalvik-zygote (deleted)@0x2e09b6 	
Ø 5 	libdvm.so 	libdvm.so@0x5764b 	
Ø 6 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x4414df 	
7 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_dispatchMemoryPressure 	mozglue/android/jni-stubs.inc
Ø 8 	libc.so 	libc.so@0x11c3b 	
9 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_dispatchMemoryPressure 	mozglue/android/jni-stubs.inc
10 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_dispatchMemoryPressure 	mozglue/android/jni-stubs.inc
Ø 11 	libc.so 	libc.so@0xdd9b 	
Ø 12 	libdvm.so 	libdvm.so@0x59a79 	
Ø 13 	libdvm.so 	libdvm.so@0x8c1bb 	
Ø 14 	core.odex 	core.odex@0xa8500 	
Ø 15 	core.odex 	core.odex@0xa8506 	
Ø 16 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x53d66 	
Ø 17 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x6e6d6e 	
Ø 18 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x41ed0a 	
Ø 19 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x3f036 	
Ø 20 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x41ecf6 	
Ø 21 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x48b878 	
Ø 22 	libdvm.so 	libdvm.so@0x7b8b5 	
Ø 23 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x48b878 	
Ø 24 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0xca58a 	
Ø 25 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x3f036 	
Ø 26 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x48b878 	
Ø 27 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x562ffe 	
Ø 28 	libdvm.so 	libdvm.so@0x5997f 	
Ø 29 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x41ecf6 	
Ø 30 	libdvm.so 	libdvm.so@0x5749b 	
Ø 31 	dalvik-zygote (deleted) 	dalvik-zygote (deleted)@0x2e09b6 	
Ø 32 	libdvm.so 	libdvm.so@0x597d1 	
Ø 33 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x269a46 	
Ø 34 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x3f036 	
Ø 35 	libdvm.so 	libdvm.so@0x20b7e 	
Ø 36 	libdvm.so 	libdvm.so@0x29ea2 	
Ø 37 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x610416 	
Ø 38 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x6bfe 	
Ø 39 	libdvm.so 	libdvm.so@0x327a6 	
Ø 40 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc (deleted)@0x6bfe 	
Ø 41 	libdvm.so 	libdvm.so@0x2fcc2

Comment 1

3 years ago
Duping to bug 1240500, since I have some speculation about a fix in there.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1240500
You need to log in before you can comment on or make changes to this bug.