cli: using mozregression with no arguments triggers a bisection on a 7-year-frame

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR
1. Run mozregression with no arguments

Results
I don't know if it's an issue that has already been discussed or the current implementation is the expected behavior.

I was trying to find how to use the cli. As I didn't provide any date, I was expecting to get an error message or the output of `mozregression --help`. Instead, I got shown old Firefox (circa 2012) for a split second and then asking me if that build is broken.

After looking more closely to the logs, I understood that a bisection between 2009 and today started.
> 0:00.10 LOG: MainThread INFO No 'bad' option specified, using 2016-01-12
> 0:00.10 LOG: MainThread INFO No 'good' option specified, using 2009-01-01
Well, it is the expected behavior - it is intended since the beginning of mozregression. But maybe now it does not make much sense, and we could default to a one year range (as we do in the GUI, fwiw), or maybe as you said just don't accept no good and bad ?

Though, maybe not providing the bad value (when you want to bisect until today) is interesting.
(Reporter)

Comment 2

3 years ago
(In reply to Julien Pagès (:parkouss) from comment #1)
> Well, it is the expected behavior - it is intended since the beginning of
> mozregression.
If it's intended since then, we might break other's people workflow. If that's the case, I don't mind closing this bug as INVALID or WONTFIX. 

Otherwise, not accepting the couple (NO_GOOD, NO_BAD) sounds tangible. I'm not sure how many people would use this "since 1 year ago" hidden feature.
Yeah, let's close this as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.