Add a Power HAL for Sony devices

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: afarden, Assigned: afarden)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

58 bytes, text/x-github-pull-request
gerard-majax
: review+
Details | Review | Splinter Review
55 bytes, text/x-github-pull-request
gerard-majax
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard-majax
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
AOSP based builds don't have a power HAL. We don't use the QCOM power HAL because it depends on QCOM proprietary blobs.

This is necessary if for when we want to control power usage from gecko.
(Assignee)

Comment 1

3 years ago
Created attachment 8706890 [details] [review]
Shinano PR
Attachment #8706890 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 2

3 years ago
Created attachment 8706893 [details] [review]
Rhine PR
Attachment #8706893 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 3

3 years ago
Created attachment 8706896 [details] [review]
Yukon PR
Attachment #8706896 - Flags: review?(lissyx+mozillians)
Assignee: nobody → afarden
Attachment #8706890 - Flags: review?(lissyx+mozillians) → review+
Attachment #8706893 - Flags: review?(lissyx+mozillians) → review+
Attachment #8706896 - Flags: review?(lissyx+mozillians) → review+
Looks good, I'm giving it a try on Z3c before merging
Looks good after flashing, PowerHAL picked up.
You need to log in before you can comment on or make changes to this bug.