Tabs Management Needs Rethinking

RESOLVED DUPLICATE of bug 1332447

Status

()

Toolkit
WebExtensions: Untriaged
--
enhancement
RESOLVED DUPLICATE of bug 1332447
2 years ago
9 months ago

People

(Reporter: ametedinov, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

The introduction of tabs into web browsers during the last decade has engendered a new kind of problem, which is now time to be addressed. A user find himself opening a new tab every time he needs to go a a different website and leaving the old tab open so that he can come back to it later. Over time, however, this behavior leads to a navigation bar filled with dozens of tabs that just are just impossible to manage.

There are 2 key aspects that need to be rethought:
1) Encourage users to close the tabs they don't use or reuse opened tabs.
2) Remind users that they may need to go back to some important tabs.
3) Provide options for users to organize opened tabs.

1&2) How to design the interface such that it leads to a change in user behavior is the question that needs addressing. The first two problems can be solved with the following implementation. The browser should analyze which tabs did the user revisited most often, and which tabs did he not revisit at all. Then, whenever he clicks (+) to open a new tab the screen that appears would present the four most frequently revisited tabs and the four least frequently revisited tabs. What he would see is the question "Do you want to close some tabs?" and under that question, he would see 4 suggestions that he can close right from that screen. Below those suggestions, he would see the second question "Do you want to revisit some tabs?", and underneath this question, 4 suggested tabs will be displayed. This implementation would help users not only manage their tabs better, but also finish work that they might have forgotten to go back to. 

3)The aforementioned implementation, would greatly reduce the presence of the third problem. Nevertheless, if a user wants to actually have a large number of tabs that they wish to remain opened, then there needs to be a better way to manage those opened tabs. The suggested implementation for for mitigating this problem is grouping. Provide a way on the navigation bar to create a supertab that looks different from a regular tab. In that supertab, a user would be able to drag esisting tabs and therefore group the dragged tabs into a category indicated by the label of the supertab. Then, rather than having 50 opened tabs that clutter the navigation bar, one would have only a couple of supertabs, within which all of the opened tabs are still present.

Updated

2 years ago
Severity: normal → enhancement
Component: Untriaged → Tabbed Browser
Keywords: uiwanted

Comment 1

2 years ago
> 1) Encourage users to close the tabs they don't use or reuse opened tabs.

Anybody could write an extension for this if anybody considers this important.

> 2) Remind users that they may need to go back to some important tabs.

Anybody could write an extension for this if anybody considers this important.
I think this is relevant to web extensions, Firefox itself is not planning to touch tabs in the near except via web extensions apis.
Component: Tabbed Browser → WebExtensions: Untriaged
Product: Firefox → Toolkit

Comment 3

9 months ago
> 3) Provide options for users to organize opened tabs.

Is doable in an extension too.

There are some controversial bugs on grouping already such as bug 1384515 and bug 1332447. Marking as a duplicate to bug 1332447 because if that gets implemented an extension can implement anything they want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1332447
You need to log in before you can comment on or make changes to this bug.