Closed Bug 1239015 Opened 4 years ago Closed 4 years ago

Stops working open a new tab from a search suggestion in locationbar(with Ctrl+click or with wheel mouse button)

Categories

(Firefox :: Address Bar, defect)

44 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 46
Tracking Status
firefox43 --- unaffected
firefox44 + verified
firefox45 + verified
firefox46 + verified
firefox-esr45 --- fixed

People

(Reporter: alice0775, Assigned: adw)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: regression


Steps to reproduce:
1. Enable search suggestion from location bar
2. Type something in location bar
3. Ctrl+click or click wheel mouse button on search suggestion item

Actual Results:
Nothing happens

Actual Results:
Search results should be open in new tab


Regression window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=fc6e4f66615258125ef090c4c3b50b42ff28b467&tochange=a78f8444400c700be312e2e653d7e2d74994900e

Regressed by: 
a78f8444400c	Drew Willcoxon — Bug 1226629 - Increment "urlbar" BrowserUITelemetry/FHR for all searchengine results clicked in the urlbar. r=mak
Flags: needinfo?(adw)
Version: 45 Branch → 44 Branch
Error in Browser Console:

TypeError: this._parseAndRecordSearchEngineAction is not a function
 urlbarBindings.xml:1473:21
Attached patch patchSplinter Review
Thank you for filing!
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
Attachment #8706992 - Flags: review?(mak77)
Drew, I'd like to this fix in Beta44 as I believe this is a critical recent regression with an easy one-liner fix. What do you think?
Flags: needinfo?(adw)
I agree, this should be no problem at all.
Flags: needinfo?(adw)
Comment on attachment 8706992 [details] [diff] [review]
patch

Review of attachment 8706992 [details] [diff] [review]:
-----------------------------------------------------------------

sigh, damn unreadable bindings.
Attachment #8706992 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/06337186cd73
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Comment on attachment 8706992 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1226629
[User impact if declined]: Ctrl+click on search suggestions won't open correctly, plus our telemetry is messed up
[Describe test coverage new/current, TreeHerder]: No tests for this bug specifically but we have related urlbar tests
[Risks and why]: Low risk, one line change, manually tested
[String/UUID change made/needed]: None
Attachment #8706992 - Flags: approval-mozilla-beta?
Attachment #8706992 - Flags: approval-mozilla-aurora?
That was fast! 
Tracking for 44+ since this is a recent regression.
Comment on attachment 8706992 [details] [diff] [review]
patch

Approved for uplift to aurora and beta, low risk fix for search related regression. 
This should make it into beta for the RC merge on Monday.
Attachment #8706992 - Flags: approval-mozilla-beta?
Attachment #8706992 - Flags: approval-mozilla-beta+
Attachment #8706992 - Flags: approval-mozilla-aurora?
Attachment #8706992 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
I've reproduced the initial issue on Nightly 46.0a1, buildID: 20160112030227. 

Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Nightly 46.0a1 (buildID: 20160118030338), latest Aurora 45.0a2 (buildID: 20160119004010) and Firefox 44 RC (buildID: 20160118143821).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.