wheelmouse randomly freezes browser, et.al. in linux

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Curtis Nelson, Assigned: asa)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204.

I haven't been able to consistently reproduce this bug but it happens so often I
think it needs to be reported.  In linux (I'm using debian) with 0.9.7 and now
0.9.8 the use of the wheelmouse locks up mozilla at seemingly random intervals.
 It locks it up so that I have to kill the whole process and start again.  At
first I thought it was only happening in the browser, but I've seen it now when
scrolling in an email message.

I have yet to be able to isolate it or consistently replicate the bug.  At one
point it seemed a certain webpage would always cause the problem.  You could go
to it, scroll down, and then it would freeze.  But it stopped doing that after a
reboot.  So it back to random intervals.  To give an example, in an 8 hour
workday, I've had it freeze about 10 times.

Comment 1

16 years ago
Reporter: Please look at bug 101854 and Bug 105880, do any of those seem familiar?
Severity: major → critical
Keywords: hang
(Reporter)

Comment 2

16 years ago
It's definitely not Bug 105880.  Hard to tell if it's the same as 101854 since
that was pretty old and there aren't a lot of details.  The webpage that was
freezing for me constantly seems to be fine as of late
(http://www.smcc.demon.nl/webcam/).  It seems to be related to how fast or slow
the loading time is for the site.  Slow sites were much more prone to freeze,
and freezes seem to happen when the page was still loading, though I did have a
few pages freeze on me when they appeared to have loaded completely.  

Unfortunately I don't have any core dumps of the problem.  At one point when I
had a site repeatig concstantly I did an strace on mozilla and it looked like it
was getting into a constant device busy response, but the report was a little
too much for me to figure out.  

I have been freeze free for the last couple of days.  If it comes up is there
anything I can do that would help capture what is going on?

Comment 3

16 years ago
You can "attach" gdb on any running process.
gdb /path/to/executeable <pid>

that would probably help a lot

Comment 4

16 years ago
I've noticed this bug a couple of times as well.
Mousewheel implementation in Linux seems very buggy at times.
Try opening a window (need not be Mozilla) in which you can scroll a lot.
Now scroll like a madman (up or down) and you will see that after a few seconds,
the scrolling will 'stutter' and freeze your machine.

So i don't think this is Mozilla only.

Comment 5

16 years ago
Reporter: Did you see the hang with the wheelmouse recently? Does is still occur
with a recent nightly, available at:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

If it still occurs with a recent nightly, please follow the instructions from
comment 3

Thanks
(Reporter)

Comment 6

16 years ago
After a reload of linux and a different X serv config (new card and no glx) I
can no longer replicate this bug.

Comment 7

16 years ago
Marking WORKSFORME

Reporter: If you want you can verify this bug
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.