Closed Bug 1239085 Opened 4 years ago Closed 4 years ago

Remove Deprecation warning from NewTabUrl.jsm

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla46
Tracking Status
firefox43 --- unaffected
firefox44 --- fixed
firefox45 --- fixed
firefox46 --- fixed
b2g-v2.5 --- fixed

People

(Reporter: ckerschb, Assigned: ckerschb)

References

Details

Attachments

(1 file)

No description provided.
Blocks: 1204983
Assignee: nobody → mozilla
No longer blocks: 1204983
Status: NEW → ASSIGNED
Attachment #8707104 - Flags: review?(oyiptong) → review+
Hi, this failed to apply:

applying bug_1239085_remove_deprecation_warning_newtaburl.patch
patching file browser/components/newtab/NewTabURL.jsm
Hunk #1 FAILED at 8
1 out of 1 hunks FAILED -- saving rejects to file browser/components/newtab/NewTabURL.jsm.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh bug_1239085_remove_deprecation_warning_newtaburl.patch
Flags: needinfo?(mozilla)
Keywords: checkin-needed
(In reply to Carsten Book [:Tomcat] from comment #2)
> Hi, this failed to apply:

Rebased and pushed myself - thanks!
Flags: needinfo?(mozilla)
Bug 1204983 landed in 44, so we should uplift that bug to not confuse our addon developers. Adding tracking flags!
Blocks: 1239783
https://hg.mozilla.org/mozilla-central/rev/82da00d42c41
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
Comment on attachment 8707104 [details] [diff] [review]
bug_1239085_remove_deprecation_warning_newtaburl.patch

Approval Request Comment
Initially we decided to deprecate NewTabUrl.jsm within Bug 1204983. After complaints from the addon authors, see comment 133 - 149 [1] we decided not to deprecate NewTabURL.jsm. In order to not confuse any addon authors we should remove the deprecation warning from all the branches.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1204983#c133

[Feature/regressing bug #]:
https://bugzilla.mozilla.org/show_bug.cgi?id=1204983

[User impact if declined]:
People using addons will see a deprecation warning in the console.

[Describe test coverage new/current, TreeHerder]:
1) Manually tested and verified!
2) Automatic test - browser_newtab_external_resource.js
(which does not precisely test the deprecation warning but makes sure no logic is breaking when removing the deprecation warning).

[Risks and why]:
low to 0, because we are only removing a deprecation warning.

[String/UUID change made/needed]:
no

@ritu: Would be good if we could consider this uplift for the next release candidate. As pointed out, the risk is basically 0, but i would confuse addon authors because they would get an incorrect deprecation warning in their console.
Flags: needinfo?(rkothari)
Attachment #8707104 - Flags: approval-mozilla-beta?
Attachment #8707104 - Flags: approval-mozilla-aurora?
Blocks: 1204983
Comment on attachment 8707104 [details] [diff] [review]
bug_1239085_remove_deprecation_warning_newtaburl.patch

Given that 1) this is a new regression in Fx44 (Fx43 is unaffected), 2) there is enough end-user feedback on the original bug requesting us to remove the deprecation warning, 3) the risk associated with the patch is very low, it seems safe to take this fix in Beta44, Aurora45.
Flags: needinfo?(rkothari)
Attachment #8707104 - Flags: approval-mozilla-beta?
Attachment #8707104 - Flags: approval-mozilla-beta+
Attachment #8707104 - Flags: approval-mozilla-aurora?
Attachment #8707104 - Flags: approval-mozilla-aurora+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.