Closed Bug 1239161 Opened 7 years ago Closed 6 years ago

Intermittent test_peerConnection_addDataChannelNoBundle.html | Test timed out.

Categories

(Core :: WebRTC, defect, P2)

43 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- fixed

People

(Reporter: KWierso, Assigned: bwc)

References

Details

(Keywords: intermittent-failure)

backlog: --- → webrtc/webaudio+
Rank: 25
Priority: -- → P2
Byron, looks like you wrote this test, based on 'hg log' -- could you take a look at this (or have someone take a look)?

This seems to be basically a perma-failure on Android, from my extremely small sample size of https://treeherder.mozilla.org/#/jobs?repo=try&revision=ded03febd68f (where 2/2 Android mda test-runs failed with this exact issue).

And from a larger sample size, it seems to be starred as failing 25+ times per day, starting on 9/25, according to recent Robot comments here.  (Possibly a regression from bug 1304269, which modified this test just before that point?)
Flags: needinfo?(docfaraday)
Another gUM deadlock here, it looks like.
Flags: needinfo?(docfaraday) → needinfo?(pehrson)
(In reply to Byron Campen [:bwc] from comment #12)
> Another gUM deadlock here, it looks like.

What do you base that on?

I checked two recent failures in orangefactor and didn't see any such evidence. I just see this particular test timing out. The ones after it times out succeed just fine. If it was a deadlock I would have expected an error like "Application timed out after 330 seconds".
Flags: needinfo?(pehrson) → needinfo?(docfaraday)
Hmm, I must have looked at an older log. The ones on android do not seem to have the same cause.
Timeout seems to occur in a consistent place. Looking closer.
Ok, this coincides with the landing of bug 1157323. Maybe we're using the timer API incorrectly somehow. Looking into it.
Assignee: nobody → docfaraday
Flags: needinfo?(docfaraday)
The android tests are *very* sensitive to perf.  99.5% of these failures are android.  Of course that doesn't mean there isn't a bug in the landing... if it fires something too much/early, that could hurt perf on android across a wide range of tests
No failures since 10/19, one of the other fixes landing got this one.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
It was disabled for Android in order to land the fake-audio-via-callbacks bug
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.