If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Audio (including Ogg and Mp3) does not play in Firefox after update to 43.0.03

RESOLVED INCOMPLETE

Status

()

Core
Audio/Video: Playback
P2
normal
RESOLVED INCOMPLETE
2 years ago
a year ago

People

(Reporter: nick, Unassigned)

Tracking

43 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151229124055

Steps to reproduce:

Consider the public-domain, Ogg-Vorbis video file here:
https://ia800309.us.archive.org/5/items/his_girl_friday/his_girl_friday.ogv



Actual results:

Downloaded and played in an external player, such as VLC, full audio and video playback performs as expected.

Played in Firefox, video playback with no audio.

Other popular sites have similar results:
Hype Machine and SoundCloud: No audio
YouTube: No audio, but video playback.


Expected results:

Full video and audio playback in-browser as well as in external player.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Can you try with a clean profile? Do you remember the last version where it worked?

There's nothing in 43.0.3 which should break ogv playback.
(Reporter)

Comment 2

2 years ago
Still no joy.
Steps:
Close firefox
In terminal: firefox -P
Create new profile, keeping "use this profile without asking" checked
Open Firefox
Navigate to https://ia800309.us.archive.org/5/items/his_girl_friday/his_girl_friday.ogv

Results:
Streams video, no audio.

So, I agree with you that this makes no sense; why does Firefox not play when other players work fine? Esp. if there have been no changes to playback, and esp. if there is audio but not video. Since Ogg is a fully open codec, this doesn't smell like a codec thing. Firefox's playback behavior also indicates nothing is wrong, that is, on Hype Machine or Soundcloud, the audio files look like they are playing; I can scan forward and back through MP3 files no problem. If Firefox was having trouble figuring out what to do with the file, we might expect different behavior.

How can I check and see where Firefox is sending audio output?

It is possible that as I cycled between output devices using menu options in VLC or in the Sound menu for GNOME, Firefox for some reason did not get the memo. Before this bad behavior started up, I watched a DVD using VLC and pushed the output over HDMI. I have noticed that sometimes if you use in-app menus to change device settings, the rest of the system occasionally does not register the change. This is occasionally true in Fedora, Windows ... it seems like the result of bad design patterns in media player software.

Could it be possible that where Firefox thinks changes to the output device settings should be stored, and where other software thinks the same settings should be, are different?
(Reporter)

Comment 3

2 years ago
Yes, the bug has to do with registering changes to audio devices.

Steps to replicate:
1. In Fedora, Sound menu, set output device to default (eg internal speakers)
2. Open media in VLC; connect device to HDMI
3. In VLC, set audio output to HDMI
4. Disconnect HDMI, close VLC
5. Fedora -> Sound, output device is still default
5. Open Firefox, play media

Expected result:
Firefox detects appropriate audio settings and sends output to default (eg internal speakers)

Observed result:
No audible sound, probably because Firefox is sending output to disconnected HDMI (please tell me how I can generate log output that will show this)

6. Connect to HDMI device eg. HDMI TV
7. Play media

Expected result:
System sound setting is still default (eg internal speakers), so we expect Firefox to play media from internal speakers.

Observed results:
Audio playback from HDMI device
Do you have pulseaudio installed? I think we rely on it for chosing the default device.
Flags: needinfo?(nick)
Priority: -- → P2
Closing for lack of followup. Please re-open if you have time to debug the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(nick)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.