Status

addons.mozilla.org Graveyard
Admin/Editor Tools
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Peter Kehl, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

Visit https://addons.mozilla.org/en-US/developers/addon/selite-testcase-debug-conte/edit logged in as its owner. Go to Technical Details near the bottom, click Edit. In 'Required Add-ons' try to enter 'Selenium IDE' (i.e. name of https://addons.mozilla.org/en-US/firefox/addon/selenium-ide/).



Actual results:

'Selenium IDE' matches many add-ons that contain 'Selenium IDE' in their name. However, the page shows an incomplete list for a dropdown. It doesn't list 'Selenium IDE'. So I can't pick it up.

Even worse, if I just enter 'Selenium IDE' (which is difficult to do: the only way I know is to copy that string to clipboard, then right click at the field and paste) and submit the form, it won't get saved as a required add-on.


Expected results:

It should
- list all matching add-ons (with a scrollbar, if need be), and/or
- accept a typed name (without selecting from the ajax dropdown), if it exactly matches an add-on name.
I can confirm the bug. It's a bit of an edge case, so I don't expect it to be fixed soon. As a workaround, you can enter 2079 in the textbox, which is the numerical ID for Selenium IDE. That should work.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

2 years ago
Jorge,

Thank you.

However, this problem affects many more extensions, because it seems that the ajax dropdown lists only up to 9-10 items.

Even worse, it seems to perform fuzzy matching, which means there are even fewer exact (partial) matches. So it won't affect only add-ons whose name is a substring of names of other add-ons, even if there are fewer than 9-10 of those other add-ons (because fuzzy matching adds extra noise and hits the limit of 9-10 items displayed).

Now I'm having a problem entering 'SeLite Extension Sequencer' (https://addons.mozilla.org/en-US/firefox/addon/selite-extension-sequencer/) as a dependency. What's its number, please?

Furthermore, would you provide steps for add-on admins to locate numbers to enter as dependencies. I've tried to get ID for SeLite Extension Sequencer. I inspected Technical Details > edit of another add-on that already has SeLite Extension Sequencer as a dependency. Using Firebug it seemed to me that its number was 464285, but that didn't work.
Flags: needinfo?(jorge)
(Reporter)

Comment 3

2 years ago
Jorge,

I won't need number for SeLite Extension Sequencer. However, the steps would be useful. They would save your time and that of others.
(In reply to Peter Kehl from comment #2)
> However, this problem affects many more extensions, because it seems that
> the ajax dropdown lists only up to 9-10 items.
> 
> Even worse, it seems to perform fuzzy matching, which means there are even
> fewer exact (partial) matches.

I consider it an edge case because very few add-ons use the "Required add-ons" feature, and only a small subset of them would run into this particular name-matching problem. It's possible only some Selenium add-ons would experience this bug.

> Furthermore, would you provide steps for add-on admins to locate numbers to
> enter as dependencies. I've tried to get ID for SeLite Extension Sequencer.
> I inspected Technical Details > edit of another add-on that already has
> SeLite Extension Sequencer as a dependency. Using Firebug it seemed to me
> that its number was 464285, but that didn't work.

That's the correct number, and it looks like you already set it as a dependency. Since the numerical ID is hidden in the source, I created this add-on to expose it in the add-on page (and do other tweaks to AMO pages): https://addons.mozilla.org/addon/amo-admin-assistant/.

That's the best workaround I can suggest. The real bug here is that the search tries to be too clever, which is a problem that pops up in other parts of the site. We'll need to revisit the search feature in the site redesign that will probably happen this year.
Flags: needinfo?(jorge)
(Reporter)

Comment 5

2 years ago
Thank you.

Alternative and smaller suggestion for a fix for that search (for that page, or other parts of AMO):
Change the dropdown matcher, so that it always includes an exact match (if there is one), before it lists any substring/fuzzy matches.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.