Connections to Google fail - disabling IPv6 fixes it

RESOLVED DUPLICATE of bug 1234548

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1234548
2 years ago
2 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I have been experiencing failures connecting to Google for some time now, across two machines.  Both run Fedora 22, and I'm using the distro-provided Firefox (43.0.3 right now).

This manifests in various ways.  It's intermittent, so I've guessed at how often the failures occur.

 * Open a new tab, type a search term, and hit enter.
   Expected: Google search results
   Actual (about 30% of the time): either
    - empty page; or
    - page containing only the Google search header, with no results or footer

 * Attach a 13MB file to a Gmail message
   Expected: File uploads successfully
   Actual (100% of the time): "Attachment Failed"

 * Send an email (either with personal or moco gmail)
   Expected: mail sends
   Actual (50%): "Oops! An error occurred and your mail was not sent"

 * Open plus.google.com
   Expected: continuously scrolling posts
   Actual (15%): limited-length list of posts, or no posts at all

I haven't seen similar behavior from non-Google sites.  For example, I uploaded that 13MB attachment to Amazon S3 without any trouble.  Bugzilla loads for me every time.  And so on.
Duplicate of this bug: 1206815
I saw similar effects a few months ago in bug 1206815, but they were far more intermittent (maybe 10% or less), although that was also with 43 when I was running nightly.  I switched to release since it fixed the bug, but now that 43 is release, I'm back where I started.

In that bug, I confirmed that this occurs with a clean profile.

I can confirm today that this prevents other googly things such as google for work administration (presumably it involves enough AJAX requests that one is guaranteed to fail, so I get an "unable to process your request" error message).

I have not had any trouble with any other sites - bugzilla loads perfectly every time, github works like a champ, and so on.

I can access the same sites from the same hosts using Chrome without any trouble.

Setting network.dns.disableIPv6 causes the problem to go away.  However, disabling IPv6 on the firewall (just taking the tunnel down) does not change the behavior.  With IPv6 enabled in both places, I see an awful lot of v6 traffic, and the SixOrNot extension indicates the google search page, for instance, is 100% v6.

How can I further debug?
Component: General → Networking
Product: Firefox → Core
Summary: Connections to Google fail → Connections to Google fail - disabling IPv6 fixes it
Are you on Linux? If you are this is probably dup of bug 1235509 or bug 1234548.

You can change pref network.notify.changed to false and see if it is working. If it is working than it is one of these bugs.

One of thesw 2 bugs is already fix on Nightly and the other has just been pushed to inbound so it will be in Nightly tomorrow.
I just saw this repeated with network.dns.disableIPv6 = true :(

I've set network.notify.changed and will report back.
Assignee: nobody → dustin
network.notify.changed seems to have fixed it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1234548
You need to log in before you can comment on or make changes to this bug.