Intermittent e10s browser_rules_edit-property-computed.js | Computed value of padding-top is as expected - Got 10px, expected 20px and several more

RESOLVED FIXED in Firefox 46

Status

()

Firefox
Developer Tools: CSS Rules Inspector
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: philor, Assigned: Sami Jaktholm)

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
Firefox 47
intermittent-failure
Points:
---

Firefox Tracking Flags

(e10s+, firefox46 fixed, firefox47 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=19696871&repo=mozilla-inbound

Updated

2 years ago
Blocks: 984139
tracking-e10s: --- → +

Comment 1

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 2
* fx-team: 2
* b2g-inbound: 1

Platform breakdown:
* windows7-32: 4
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1239208&startday=2016-01-11&endday=2016-01-17&tree=all

Comment 2

2 years ago
53 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 25
* mozilla-inbound: 18
* b2g-inbound: 5
* try: 3
* mozilla-central: 2

Platform breakdown:
* linux32: 32
* linux64: 16
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1239208&startday=2016-01-18&endday=2016-01-24&tree=all
(Assignee)

Comment 3

2 years ago
Created attachment 8713988 [details] [diff] [review]
bug-1239208-intermittent-rules-edit-property-computed.patch

Here's a patch. The logs show [1] how the setRuleText() from the inplace-editor commit is still pending when the test ends so the reason outlined in the commit message is likely the cause of the intermittents.

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=5eda4aa68bf6

[1] https://treeherder.mozilla.org/logviewer.html#?repo=fx-team&job_id=6934547#L9148
Assignee: nobody → sjakthol
Status: NEW → ASSIGNED
Attachment #8713988 - Flags: review?(pbrosset)

Comment 4

2 years ago
71 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 30
* fx-team: 25
* mozilla-central: 10
* try: 4
* b2g-inbound: 2

Platform breakdown:
* linux32: 47
* linux64: 19
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1239208&startday=2016-01-25&endday=2016-01-31&tree=all
Comment on attachment 8713988 [details] [diff] [review]
bug-1239208-intermittent-rules-edit-property-computed.patch

Review of attachment 8713988 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for fixing this. Indeed, previewing a change does cause a ruleview-changed event, and waiting for this event is the right way of making sure there won't be pending requests when the test ends.
Attachment #8713988 - Flags: review?(pbrosset) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 6

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/eb673021691c
Keywords: checkin-needed

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/eb673021691c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47

Comment 8

2 years ago
26 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 10
* mozilla-aurora: 7
* fx-team: 5
* try: 2
* mozilla-central: 2

Platform breakdown:
* linux32: 15
* linux64: 7
* windows7-32: 3
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1239208&startday=2016-02-01&endday=2016-02-07&tree=all

Comment 9

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/74549922e503
status-firefox46: --- → fixed
You need to log in before you can comment on or make changes to this bug.