Closed Bug 1239386 Opened 4 years ago Closed 3 years ago

Add donations to Thunderbird start page

Categories

(www.mozilla.org Graveyard :: Thunderbird, defect)

Production
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: grahamperrin, Assigned: mkmelin)

References

()

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; FreeBSD amd64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151231141035

Steps to reproduce:

The default URL for start page content, 
https://live.mozillamessaging.com/thunderbird/start?locale=en-US&version=38.5.0&os=FreeBSD&buildid=20151231144939


Actual results:

refers to an October 2014 reorganisation 
https://blog.mozilla.org/thunderbird/2014/11/thunderbird-reorganizes-at-2014-toronto-summit/
as "recent"


Expected results:

Given 2015 discussions such as 
https://groups.google.com/forum/#!msg/mozilla.governance/kAyVlhfEcXg/Eqyx1X62BQAJ 
there must be something more appropriate as a start page; something more pertinent than the 2014 reorganisation. 

https://blog.mozilla.org/thunderbird/2015/12/thunderbird-active-daily-inquiries-surpass-10-million/ maybe?
Sorry, I could have been clearer. I'm not sure how things are woven together. 

At the URL given by Kent, 

> … contributors recently organized to focus on the future …

– with the link through to the 2014 event, which (given changes during 2015) is probably not the best example of recent changes relating to organisation.
OK I see your point. What we really need is a few volunteers to regularly update our websites.
Component: Untriaged → Thunderbird
Product: Thunderbird → www.mozilla.org
Version: 38 → Production
Status: UNCONFIRMED → NEW
Ever confirmed: true
I drafted the text for the 2014 revision done in bug 1103396.  I've been thinking about an update to the page in recent months, because I'd like to do more than revise the text. 

Actually I'd like to future-proof/make it so we can mostly avoid needing to revise it in the future. Some possibilities include:
* Adding an FAQ link - something we've lacked for years (which https://www.mozilla.org/en-US/thunderbird/ also lacks).  But I'd like to know what the UI folks think about this - does it tend to cause users to ignore all the other links for example?
* Perhaps a link to a page that lists current most common problems. Or perhaps it should be on https://support.mozilla.org/en-US/products/thunderbird ?)
* Adding a mechanism, such as firefox has, to alert users when they too far behind in releases

Preferably without significantly increasing the number of links in https://www.mozilla.org/en-US/thunderbird/release/start/?uri=/thunderbird/start/

Also want to do something similar for beta channel. At least 30% of the users there are on releases older than 38.
It would really be good to update this for the Thunderbird 45 release.

When doing this, we should add a link to our new donate site:

(link that stands by itself): https://donate.mozilla.org/en-US/thunderbird/about/

(link to use when a previous page gives a description of donating to Thunderbird): https://donate.mozilla.org/en-US/thunderbird/
Let's use this bug as the location to discuss updating the start page to include at least a link for the Thunderbird-specific donate link, as well as other appropriate refreshes. But the most urgent issue is the donate link.
The current text most amenable to replacing/changing is 

Contribute to Thunderbird

To ensure that Thunderbird continues to improve, as it has for the last ten years, active contributors recently organized to focus on the future. Now is a great time for you to get involved. Please help us assist users of Thunderbird, and improve the Thunderbird product and eco-system.

We look forward to hearing from you.
---------

Wordsmithing has already been done for https://donate.mozilla.org/en-US/thunderbird/about/ 
So we shoulod probably borrow some words from there.
Summary: Thunderbird start page is outdated → Add donations to Thunderbird start page
For wordsmithery I created https://public.etherpad-mozilla.org/p/bug1239386
Attached image tb-startpage.png (obsolete) —
Something like this?
Assignee: nobody → mkmelin+mozilla
Really nice wording, thanks for doing this Magnus!

My only concern, and this may not really be an issue, is that I think that we need to do an intrusive annual campaign, and that was assuming that the start page would be a little lighter on pushing donations. Maybe we could move the "why we need donations" to a link somewhere to make this page a little shorter?

But what you have is better than what we have now, so feel free to ignore my advice.
Nice solid wording indeed. I'm inclined to keep the "Why..." as being part generally informative, part motivator. And the page is already there, the text isn't blocking anything so I don't see it as at all intrusive.  Though I'd like to see it shortened if possible by 20-30%.

(Plus, I think a user is not likely to click a link like "click here for why/more info...".)
(In reply to Magnus Melin from comment #8)
> For wordsmithery I created https://public.etherpad-mozilla.org/p/bug1239386

magnus can you add to the etherpad the text from "why do we need.."?
Flags: needinfo?(mkmelin+mozilla)
Yeah I added that. I'll create a PR as soon as bug 1272972 is resolved, since otherwise linking is trickier.
Flags: needinfo?(mkmelin+mozilla)
See my significant edit at https://public.etherpad-mozilla.org/p/bug1239386   It may seem a bit severe, but my goal was to keep Mangus' key ideas but greatly shorten and strengthen the message.
I like the shorted version. I was going to comment  that "While ads would generate income, we would greatly prefer other funding alternatives." sounds like we are threatening to have ads if this fails (which we are not) but I see that has been removed.
Attached image tb-startpage-2.png (obsolete) —
Updated, with parts of Wayne's suggestions.
Attachment #8756020 - Attachment is obsolete: true
Attachment #8760083 - Flags: feedback?(vseerror)
I think "underlaying" is not the correct english terminology. You probably want to use "underlying" or some other term. 

Also, the last sentence I suggested may seem redundant, too foward, or out of place (being under "Why do we need donations") but I think it would be good to close that last paragraph with something like "So we need for your support, and ask for your generous donation today." - feel free to wordsmith.  The reason I suggested it originally is we are more likely to get results if the objective is restated and our message closed with the action we wish the users to take, i.e. the subtle hint.
Yes, that's indeed a typo, thx!

Re the last sentence: I wanted the text to say (as well as we can at this point) what the money would be used for. Your text did not really say that. I didn't want to restate the "donate!" as surely someone reading through it already would be get the drift. It's somewhat forward but this text is all a balance of not sugar coating the situation and at the same time not sound too desperate.
Two general comments.

First, you've given enough donation context that you should not be linking to the "with context" link but the "without context" link. That is, use https://donate.mozilla.org/thunderbird/  (the "about" link is intended for a simple "donate" button with much less content. This is not my distinction BTW but a standard MoFo distinction in their design).

Second, the reasons that you give are all of the things users don't care about, infrastructure and platform changes. Yes we know that the money needs to go mostly to that, but I think that we at the same time need to try to address real user issues as we can - long-standing bugs, frequently requested features, etc.

Now the way that we address them might not be paying someone to do it, it might be having a nice meetup where we have a working vacation at a nice destination to thank the contributors who are making a difference. Still, if you are going to provide context for the donation, I think it needs to be a little more friendly to the user's perspective of missing features and unfixed bugs. Better to be a little vague than it is to emphasize things that the user may not really understand or care about.
Comment on attachment 8760083 [details]
tb-startpage-2.png

essentially + per my previous comments
Attachment #8760083 - Flags: feedback?(vseerror) → feedback+
Attached image tb-startpage3.png
Ok, latest suggestion.
Attachment #8760083 - Attachment is obsolete: true
Attachment #8761161 - Flags: review?(vseerror)
Comment on attachment 8761161 [details]
tb-startpage3.png

Perfect
Attachment #8761161 - Flags: review?(vseerror) → review+
Comment on attachment 8761161 [details]
tb-startpage3.png

Yes I agree, looks great!
Attachment #8761161 - Flags: feedback+
https://github.com/mozilla/bedrock/pull/4181

we should probably add something to the other start page versions too (beta, daily, earlybird).
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/e95aae20bea761ff534db4ac55f0ee1f7cd5476e
Bug 1239386 - Add donations to Thunderbird start page.

https://github.com/mozilla/bedrock/commit/d1b395047a1fd76df25b1c50a063d39086aa8ecf
Merge pull request #4195 from alexgibson/mkmelin-bug1239386_tb_startpage

Bug 1239386 - Add donations to Thunderbird start page.
http://www.mozilla.org/en-US/thunderbird/release/start/ is now live. AIUI, it will show up for other locales when they have translated it.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
There's been a couple of comments on the donations mailing list about this page not working...have we looked into that at all? Is that work being tracked?
(In reply to Patrick Cloke [:clokep] from comment #28)
> There's been a couple of comments on the donations mailing list about this
> page not working...have we looked into that at all? Is that work being
> tracked?

can you be more specific with citations?
6/29/16, 12:39 PM
> I was trying to donate and the page will not respond when I click debit/credit, also the blue boxes that usually have amounts in them are blank. 

6/30/16, 12:21 PM
> I was unable to donate...I clicked the appropriate spots and 'submitting' came up, but did not continue.  What to do?

There was also some other questions, but not about it not working.
https://www.mozilla.org/en-US/thunderbird/release/start/ looks good to me, thanks folks. 

I suggest one correction before translations begin: 

> Why do we need donations

That heading should either: 

a) have a question mark '?' at its tail; or 

b) lose the word 'do' (become a statement, not a question).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Just donated, worked for me though I did spot some bugs: had to click a few times to sign up to the newsletter, and the links on https://donate.mozilla.org/en-US/thunderbird/share/ are wrong. The newsletter might have been a fluke (or bug in mailchip?), will file a bug about the /share/ page links.

@Graham: I suppose the "do" world could go. That shouldn't stop translations though.
(In reply to Graham Perrin from comment #31)
> https://www.mozilla.org/en-US/thunderbird/release/start/ looks good to me,
> thanks folks. 
> 
> I suggest one correction before translations begin: 
> 
> > Why do we need donations
> 
> That heading should either: 
> 
> a) have a question mark '?' at its tail; or 
> 
> b) lose the word 'do' (become a statement, not a question).

Fwiw, (I believe) translations for the mozorg page have already begun. Unless there is a glaring error I would suggest it's not worth pinging localizers again for a minor string change.
(In reply to Magnus Melin from comment #32)
> @Graham: I suppose the "do" world could go. That shouldn't stop translations
> though.
So how hard is it to remove one word from the page? And do we have someone who can check the punctuation?

  But to survive long term,(?) the project needs funding.
There are a few other spots where I'd add or lose a comma.
(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #34)
> (In reply to Magnus Melin from comment #32)
> > @Graham: I suppose the "do" world could go. That shouldn't stop translations
> > though.
> So how hard is it to remove one word from the page? And do we have someone
> who can check the punctuation?
> 
>   But to survive long term,(?) the project needs funding.
> There are a few other spots where I'd add or lose a comma.

Ideally grammar and punctuation should be checked and approved by someone here before you submit your changes to bedrock. Our translations are mostly done via contributors to the project, so asking them to re-translate strings a second time due to very minor changes is something we try and avoid doing as much as possible. That said, if there are any glaring errors or something is inaccurate then it cannot be avoided.
(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #34)
> So how hard is it to remove one word from the page? 

If you thought localization inside tb seems complex when you have to rev the localization key, here you'd actually have to have to if-clause every single change in the code :( Terrible really.
(In reply to Magnus Melin from comment #36)
> (In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #34)
> > So how hard is it to remove one word from the page? 
> 
> If you thought localization inside tb seems complex when you have to rev the
> localization key, here you'd actually have to have to if-clause every single
> change in the code :( Terrible really.

This isn't strictly true for all changes. For major changes we can show different templates based upon an active translation flag. For minor changes to an existing template we can use conditionals in the template, or alternatively just wait for localisers to translate before pushing out changes (the former is faster but messier).
How do I go about it to wait for localizers to translate before pushing out changes?
(In reply to Magnus Melin from comment #38)
> How do I go about it to wait for localizers to translate before pushing out
> changes?

You usually need to explicitly ask us not to merge it and wait until translators are finished before it goes to production. This doesn't change the fact that once translators have started strings are pretty much considered "frozen" either way.
What would happen if you simply removed "do"? Would hell break loose then?

Those who haven't translated, and I haven't seen any live translations yet, not even en-GB, would translate the new version, and those who have translated, would have omitted the "superfluous" "do" in their translation anyway (or left it in and added a question mark).

I don't think that removing "do" (or changing the punctuation) has any effect on the translated text.
(In reply to Alex Gibson [:agibson] from comment #39)
> You usually need to explicitly ask us not to merge it and wait until
> translators are finished before it goes to production. 

But if my PR isn't merged, who could find the code to translate? 
And when you say "ask us", where who and how? (Sorry, didn't find good docs about this.)
(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #40)
> What would happen if you simply removed "do"? Would hell break loose then?

Currently it's behind a "tag", which localizers opt in for once localized. If strings change at all after that you could have say the French start page showing partly English content for the sentence/sentences there's no localization for. If I understood it correctly.
Any change to the original string (no matter how tiny) will break existing translations and locales would start to show the old text again. Locales don't become active automatically right now, but that doesn't mean translators have not already been sent the strings or begun work. That said, let me check on the status so we know for sure. Seeing as the change is in production i'd be surprised if work had not yet begun, but it's worth checking.
(In reply to Magnus Melin from comment #41)
> (In reply to Alex Gibson [:agibson] from comment #39)
> > You usually need to explicitly ask us not to merge it and wait until
> > translators are finished before it goes to production. 
> 
> But if my PR isn't merged, who could find the code to translate? 
> And when you say "ask us", where who and how? (Sorry, didn't find good docs
> about this.)

Our localisation team can extract strings from a PR branch and push them out to localisers prior to it merging. But for this to happen strings need to be considered "final" on your end.
(In reply to Alex Gibson [:agibson] from comment #43)
> Any change to the original string (no matter how tiny) will break existing
> translations and locales would start to show the old text again. Locales
> don't become active automatically right now, but that doesn't mean
> translators have not already been sent the strings or begun work. That said,
> let me check on the status so we know for sure. Seeing as the change is in
> production i'd be surprised if work had not yet begun, but it's worth
> checking.

Correction, in this case where we used an l10n tag breaking a string would likely indeed start showing untranslated text.
OK, I just double checked with our l10n team and these strings have not been pushed out (luckily). They are waiting for another to PR merge before pinging localizers. The l10n team are now holding off translating this change until you sort out what your text should say.

To be absolutely clear, *no other pages outside en-US* will now see your donation copy until you fix what you want to say.

Please open a new PR as soon as you have finalized your text and we can get the ball rolling again. Thanks.
"Payed" is not a word in the context you're using it in, so please make sure this doesn't end up in the final copy. "Paid" is correct, being the past tense of "pay".
Ok, so changes so far:

 - remove the do
 - payed -> paid

Anything else?
Punctuation? I'm not native enough (only 16 years in Australia) to understand English punctuation rules, which even the natives haven't mastered. Who's good at punctuation?
Flags: needinfo?(dave.koelmeyer)
I’m not a native English speaker but would probably add comma’s here:

- By donating, you
- long term, the project
- Being independent, we can

Also wonder if the second comma can/should be left out here:
- evolve, we need your support and ask

And I have some serious doubts about "on" vs. "in":
- answered in the Knowledge Base
- answered in our support Forum (less bad than the above, but still)

But I might be wrong; best to have these remarks checked by a native/good English proofreader.
Hi

Native English speaker passing through.

(In reply to Ton from comment #50)
> I’m not a native English speaker but would probably add comma’s here:
> 
> - By donating, you
> - long term, the project
> - Being independent, we can

I agree with the first two.  The third I agree with, but the second comma (prior to the "and") can go.

> 
> Also wonder if the second comma can/should be left out here:
> - evolve, we need your support and ask

Yes, the second comma can be left out.
 
> And I have some serious doubts about "on" vs. "in":
> - answered in the Knowledge Base
> - answered in our support forum (less bad than the above, but still)

I would vote for "in" for both cases.  For example: You walk "in" to a library to read a book.  The Romans went "in" to the forum to debate.

I hope this helps.
So in total ;-) - only quoting paragraphs with changes.

Why ** we need donations

You might already know that Thunderbird improvements are no longer *paid* for by Mozilla. Fortunately there is an active community keeping it running and developing it further. But to survive long term*,* the project needs funding.

Thunderbird is currently transitioning to an independent organization. Being independent*,* we can shape our own fate, but there is significant infrastructure that must be maintained to deliver the application to our tens of millions of users. For Thunderbird to survive and continue to evolve, we need your support** and ask for your donation today. All the money donated will go directly to funding Thunderbird development and infrastructure.

If you like Thunderbird, please consider a donation! By donating*,* you will help us to continue delivering an ad-free top-notch email client. <Link: Make a donation>

Most Thunderbird support questions are answered *in* the Knowledge Base. If you can’t find an answer, ask your question *in* our support forum.
Magnus, I think we've settled the punctuation issues. Can you please finalise the page so that the translations can start.
Flags: needinfo?(dave.koelmeyer) → needinfo?(mkmelin+mozilla)
We're going to expose all pending requests early next week. If you want to get this translated, I suggest to fix it before the end of the week, otherwise it will have to wait for the next export.
Made the changes: https://github.com/mozilla/bedrock/pull/4220
Flags: needinfo?(mkmelin+mozilla)
Sorry to be picky, I can't see:
If you like Thunderbird, please consider a donation! By donating*,* you will ...

Am I missing something? Or maybe we decided not to put the comma there? See:
https://www.google.com.au/?gws_rd=ssl#q=%22by+donating%2C+you+will%22
I added that comma too now. Sorry for the slow response, I was away AFK for a while.
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/04fad4f352a8e7c68e4b47537a3dc1fc4748914c
Bug 1239386: Updates to "add donations to Thunderbird start page".

https://github.com/mozilla/bedrock/commit/0091e40899dcee9dccc214515b01db33f83fe87f
Merge pull request #4220 from mkmelin/tb_donation_startpage.updates

Bug 1239386: Updates to "add donations to Thunderbird start page".
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
Thx Alex!
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.