Missing key bindings in text entry fields

RESOLVED INVALID

Status

()

Core
Layout
--
major
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Kumaran Santhanam, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205
BuildID:    2002020511

Missing key bindings in text entry fields:
  - Delete key
  - Ctrl+Shift+Home
  - Ctrl+Shift+End

This is a serious problem, since it makes it very difficult to
select and delete the entire text entry field using just the
keyboard.



Reproducible: Always
Steps to Reproduce:
1) Open www.google.com

2) Type some words into the text entry field

3) Type Ctrl+A

4) Press the Delete key
   - It doesn't do anything

5) Press Ctrl+D
   - This works properly

6) Press Ctrl+Shift+End
   - It doesn't do anything
   - It's supposed to go to the end of the
     field, selected all text from the cursor

7) Press Ctrl+E, then Ctrl+Shift+End
   - Same problem as #6


Actual Results:  See above.

Expected Results:  It should have processed the keystrokes as it did in 0.9.7.
It's mysterious why those bindings have vanished in this release.

Comment 1

16 years ago
The simplest way to select all in url-field is hitting Esc. (and backspace to
delete all)

3) & 4):  Ctrl+A is an emacs keybinding honored by mozilla, and it moves cursor
to start of line. See bug 72352.

6) WFM (linux CVS) - whole line is selected.
Was the cursor at beginning of line when you hit ctrl+shift+end?
(Ctrl+shift+home works when cursor is at end of line.)

7) ctrl+e goes to end of line - ctrl+shift+home selects all.

Suggesting dup of bug 72352
(Reporter)

Comment 2

16 years ago
This turned out to be an installation issue.

When Mozilla 0.9.7 was upgraded to 0.9.8, it seems that something
may have been left behind in the X server which caused these bindings to
disappear.

I killed X11 completely, then restarted and the problem has disappeared.
As such, this is not a bug, and I apologize for any inconvenience.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.