Closed Bug 1239490 Opened 4 years ago Closed 3 years ago

32-bit plugins don't work in OS X builds made with the 10.11 SDK

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: smichaud, Unassigned)

References

()

Details

The plugin never gets displayed -- the space where it should appear stays blank.

By running the firefox binary (in Terminal) with the MOZ_DEBUG_CHILD_PROCESS environment variable set, I discovered that the plugin-container process exits (with return value 1) very shortly after it started.  It doesn't crash.

This only happens with 32-bit plugins (i.e. Silverlight but not Flash).

It only happens in builds made with the 10.11 SDK.  10.10 and below are fine.

So far I've only tested on El Capitan (OS X 10.10.2).  I tested with universal self-builds.

I have no idea why this happens, and I don't know whether I'm going to take the trouble to find out.  Fortunately the problem isn't urgent -- it will (presumably) be quite a while before we need to start doing builds against the 10.11 SDK.
The same problem happens with QuickTime (e.g. http://www.apple.com/trailers), which is also 32-bit only.
By the way, I've discovered that even the latest version of XCode (7.2), running on OS X 10.11.2 (El Capitan), can use older SDKs when compiling (if you copy them from other (older) XCode installations' SDKs directories).  I tested back to the 10.7 SDK.  That makes this bug even less urgent.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.