If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser_tab_dragdrop.js is going to permafail in e10s mode when Gecko 45 merges to Beta

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(e10s?, firefox45+ disabled, firefox46+ unaffected, firefox47 unaffected)

Details

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: Merge day test bustage

Affects all platforms, e10s mode only.

https://treeherder.mozilla.org/logviewer.html#?job_id=15420998&repo=try

563 INFO TEST-START | browser/base/content/test/general/browser_tab_dragdrop.js
TEST-INFO | started process screenshot
TEST-INFO | screenshot: exit 0
564 INFO checking window state
565 INFO Entering test
566 INFO TEST-PASS | browser/base/content/test/general/browser_tab_dragdrop.js | tab1 -
567 INFO TEST-PASS | browser/base/content/test/general/browser_tab_dragdrop.js | tab3 -
568 INFO TEST-PASS | browser/base/content/test/general/browser_tab_dragdrop.js | tab4 -
569 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_tab_dragdrop.js | Test timed out -
MEMORY STAT | vsize 906MB | vsizeMaxContiguous 575MB | residentFast 277MB | heapAllocated 93MB
570 INFO TEST-OK | browser/base/content/test/general/browser_tab_dragdrop.js | took 45015ms
Not taking screenshot here: see the one that was previously logged
571 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_tab_dragdrop.js | Found a tab after previous test timed out: data:text/html;charset=utf-8,<body%20onload='clicks=0'%20onclick='++clicks'><embed%20type="application/x-test"%20allowscriptaccess="always"%20allowfullscreen="true"%20wmode="window"%20width="640"%20height="480"></embed> -
Not taking screenshot here: see the one that was previously logged
572 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_tab_dragdrop.js | Found a tab after previous test timed out: data:text/html;charset=utf-8,<title>tab1</title><body>tab1<iframe> -

http://mozilla-releng-blobs.s3.amazonaws.com/blobs/try/sha512/8a52a7ebd6e360c00a45ed2311e8df55b6327fbe8bfc70ca9559a31ccde7eea0cb31b5c1ff4a8aa2d36ab31cb60bbb12783ea61314d7c7e05587562bd743de2d
http://mozilla-releng-blobs.s3.amazonaws.com/blobs/try/sha512/09ea7ab8f14d408184bfbfccdd03a4bb83e52bd88f919861822810d81f8a34ddaeddfc4f2095dcea56a8638730a72dd79b1fab61134b7d4cbb68dd1bac82c3b2
http://mozilla-releng-blobs.s3.amazonaws.com/blobs/try/sha512/4ccd9362fc64d970bd2aea516ff391d7c4bb4b8851a3cc573bae7326a0893cd76f40b763027560a4582978b3b0fbee98f551876ef9ee1defad53fcf1e5474f1c
Flags: needinfo?(mrbkap)
Tracking for 45+ since merge day is coming up in a week.
tracking-firefox45: ? → +
tracking-firefox46: ? → +
(Reporter)

Comment 2

2 years ago
Confirmed that disabling the test can fix the orange w/o any problems further down the line.
https://hg.mozilla.org/releases/mozilla-beta/rev/69ccdd197303
status-firefox45: affected → fixed
(Reporter)

Updated

2 years ago
status-firefox45: fixed → disabled
(Reporter)

Comment 4

2 years ago
Beta uplift simulation runs on top of 46 and 47 aren't hitting this, so I vote that we leave the test disabled on 45 and just close the bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: affected → unaffected
status-firefox47: --- → unaffected
Flags: needinfo?(mrbkap)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.