attribute selector parsing regression

VERIFIED FIXED in M16

Status

()

defect
P3
major
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({css2})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand, )

Attachments

(2 attachments)

DESCRIPTION:  I think (although I'm not sure) that this is a regression due to
introduction of CSS3 namespace support.  You do not parse the following
correctly:

[lang|="en"]

However, this works:

[lang |="en"]

STEPS TO REPRODUCE:  Load the attached test case.

ACTUAL RESULTS:  First line is green.  Second is black.

EXPECTED RESULTS:  Second line should instead be blue.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-08-20-13-M10
 * Linux, viewer, 1999-06-11-08

WORKS CORRECTLY ON:
 * Linux, viewer, 1999-06-01-13

ADDITIONAL INFORMATION:  I don't think this is a problem with the current
namespaces draft, but you might want to check.
ALSO DOES NOT WORK CORRECTLY ON:
 * Windows, apprunner, 1999-08-24-09-M10
Moving non-beta 1 items to M15
Summary: attribute selector parsing regression → {css2} attribute selector parsing regression
Reassigning peterl's bugs to myself.
Accepting peterl's bugs that have a Target Milestone
Pushing my M15 bugs to M16
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Summary: {css2} attribute selector parsing regression → attribute selector parsing regression
I took a look at this bug, and I found what seems to be a fix for it.  It's an
ugly fix, but I don't see an elegant way to do this.  (See
http://lists.w3.org/Archives/Public/www-style/2000Apr/0048.html for the
problem.)  I haven't tested the fix much yet.  Would you want to use a patch
this ugly?
Technically, the CSS grammar handles this by having separate tokens for ~= and
|= .  That would be a much cleaner fix, although it might be a little more work
(though perhaps not).  I'll have a look...
I have a much cleaner fix for this bug (changes the tokenization instead). 
Stealing bug.
Assignee: pierre → dbaron
Status: ASSIGNED → NEW
Accepting bug.  (Fix awaiting review.)
Whiteboard: fix in hand
Status: NEW → ASSIGNED
Fix checked in 2000-04-26 17:12 PDT.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Marking VERIFIED FIXED on:
- MacOS9 2000-07-06-08-M17 Commercial
- Linux6 2000-07-09-20-M17 Commercial
- Win98  2000-07-09-21-M17 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.