change ThreadLocal to template-based implementation

REOPENED
Unassigned

Status

()

Core
MFBT
REOPENED
3 years ago
a year ago

People

(Reporter: tromey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
After bug 757969, ThreadLocal uses ifdefs everywhere to handle
platform differences and the use of __thread.

Instead, as pointed out in https://bugzilla.mozilla.org/show_bug.cgi?id=757969#c17,
it would be nice to replace this with template specializations
for each case.
(Reporter)

Comment 1

a year ago
This is obsoleted by the work being done in bug 1348419.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1348419
(Reporter)

Comment 2

a year ago
Reopening because bug 1348419 changed course, and so there is still the ThreadLocal wrapper.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.