Closed Bug 1240030 Opened 4 years ago Closed 3 years ago

Certificate selection dialog appears while typing in location bar

Categories

(Firefox :: Address Bar, defect)

43 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1233982

People

(Reporter: david.balazic, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

Start typing into the location bar.


Actual results:

A certificate selection dialog popped up.


Expected results:

Let me type the URL to the end without being interrupted by a dialog.
This is similar to bug 1178358, except that is started happening around v42* instead of stopping then.

* I think it appeared with the new location bar feature that asks about "improving search experience with suggestions" with YES/NO buttons.

More details:
It seems the problem occurs when the typed characters match the URL of a SSL site the requires client cert authentication (aka two-way SSL) and that URL is then added to the suggestion list or even inserted into the location bar.
PS: There is a two-way SSL test site at https://www.bennish.net/certs/ where a client certificate can be downloaded and has a test page. Also https://www.whitepages.mil/ seems to accept any certificate (it opens the selection dialog, but after that is does not load).
They may be of assistance for testing.

Or simply set up one locally in 5 minutes, see bug 1231406 for instructions (follow the link).
This is reproducible in new profile?
Component: Untriaged → Location Bar
Flags: needinfo?(david.balazic)
(In reply to YF (Yang) from comment #3)
> This is reproducible in new profile?

Yes it is.

After creating a new profile, I:
 - imported a client certificate
 - opened a website that requests it (typed in the URL into the location bar)
 - selected the certificate in the dialog
 - exit FF
 - start FF
 - in the location bar start typing the same URL

After two keypresses the certificate dialog appears.

Note: the above examples (bennish and whitepages) do not reproduce this error.

Reasons are (I guess):
 - bennish requires a client cert only if accessing the URL https://www.bennish.net/certs/login
 - www.whitepages.mil - allows for any cert issuer in the selection dialog, but then later the ssl handshake fails

OK, I checked with a local tomcat, as described in bug 1231406 and it is reproducible:
 - setup and start tomcat as described there
 - start FF (with new profile)
 - import the my3.p12 certificate (password: test)
 - open https://localhost:8443/a/a.jsp
 - accept the server certificate permamently
 - after the page is loaded, exit FF
 - start FF
 - type "lo" into the location bar

Result: The certificate selection dialog appears.
Flags: needinfo?(david.balazic)
Might be related to bug 902439 ( or its dependent, bug 910207 )
Hmmm, looks the urlbar get the https://www.bennish.net/favicon.ico when typing, it maybe will lead to an ask if the site require a certificate. But, I don't have an environment to verify it. Add the See also to seek info.
See Also: → 910207
Same here, every time I type 'k' the site of the local cadastre at https://kais.cadastre.bg/ gets quieried. However, when I select "Cancel" in the certificate dialog, this stops happening until I close the browser and open it again.
Duplicate of this bug: 1242267
I think this was
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233982
You need to log in before you can comment on or make changes to this bug.