Refreshing page uses the URL before redirect

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: xidorn, Assigned: bnicholson)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios2.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
It seems if you visit page A which redirects to page B, when you refresh the page, the browser request page A again, instead of requesting the url in address bar, which should be page B.

This affects Bugzilla, so I have a simple STR:
1. comment on a bug and submit
2. wait until the changed bug page load
3. refresh the page

Expected result:
the bug page is refreshed

Actual result:
process_bug.cgi is requested again, which would then show
> You apparently didn't choose any bugs to modify.
tracking-fxios: --- → ?
Hardware: Other → All
Summary: Refreshing page uses the url before redirect → Refreshing page uses the URL before redirect
tracking-fxios: ? → 2.0+
(Assignee)

Comment 1

3 years ago
Likely caused by RDS where we decided to do this intentionally to avoid desktop -> mobile redirections. I'll verify this and handle these cases separately.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Created attachment 8710227 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1462
Attachment #8710227 - Flags: review?(etoop)
(Assignee)

Updated

3 years ago
Blocks: 1109675
Comment on attachment 8710227 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1462

LGTM. Works.
Attachment #8710227 - Flags: review?(etoop) → review+
(Assignee)

Comment 4

3 years ago
https://github.com/mozilla/firefox-ios/commit/2477f82b5b9ddffbea8a415aca9b71373f8c0520
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.