Trunk M099 crash switching themes [@ nsCSSFrameConstructor::ContentStatesChanged]

VERIFIED WORKSFORME

Status

Core Graveyard
Skinability
--
critical
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: jay, Assigned: David Hyatt)

Tracking

({crash, qawanted, topcrash+})

Trunk
x86
Windows NT
crash, qawanted, topcrash+

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT3], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
This is happening on all flavors of Windows with Mozilla 0.9.8 and recent
MozillaTrunk builds.  It might be related to other skinability bugs (like bug
116038), but I'm not sure.  Here is the latest from Talkback:

Mozilla 0.9.8:

Count   Offset    Real Signature
[ 12   nsCSSFrameConstructor::ContentStatesChanged 7027b3a2 -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 9   nsCSSFrameConstructor::ContentStatesChanged 4f833dfe -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 4   nsCSSFrameConstructor::ContentStatesChanged 712bfd60 -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 3   nsCSSFrameConstructor::ContentStatesChanged 7bd329ac -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 2   nsCSSFrameConstructor::ContentStatesChanged 248a265e -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 2   nsCSSFrameConstructor::ContentStatesChanged 09f7c295 -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 1   nsCSSFrameConstructor::ContentStatesChanged bda6d68d -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 1   nsCSSFrameConstructor::ContentStatesChanged 8ccca504 -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 1   nsCSSFrameConstructor::ContentStatesChanged 489ce169 -
nsCSSFrameConstructor::ContentStatesChanged ]
[ 1   nsCSSFrameConstructor::ContentStatesChanged 437f76b1 -
nsCSSFrameConstructor::ContentStatesChanged ]
 
     Crash date range: 2002-02-04 to 2002-02-05
     Min/Max Seconds since last crash: 6 - 14767
     Min/Max Runtime: 66 - 15481
     Keyword List : theme(6),  
     Count   Platform List 
     25   Windows NT 5.0 build 2195
     4   Windows NT 5.1 build 2600
     3   Windows 98 4.10 build 67766446
     2   Windows 98 4.90 build 73010104
     2   Windows 98 4.10 build 67766222
 
     Count   Build Id List 
     36   2002020409
 
     No of Unique Users        31
 
 Stack trace(Frame) 

	 nsCSSFrameConstructor::ContentStatesChanged
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 9984] 
	 StyleSetImpl::ContentStatesChanged
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1482] 
	 PresShell::ContentStatesChanged
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5101] 
	 nsXULDocument::ContentStatesChanged
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp  line 1942] 
	 nsEventStateManager::SetContentState
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 3428] 
	 nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 1539] 
	 PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 6009] 
	 PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5911] 
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 387] 
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 344] 
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 344] 
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 344] 
	 nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1909] 
	 HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 83] 
	 nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 854] 
	 nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 871] 
	 nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4529] 
	 ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4779] 
	 nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 3453] 
	 nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 1116] 
	 USER32.DLL + 0x2e98 (0x77e12e98)  
	 USER32.DLL + 0x30e0 (0x77e130e0)  
	 USER32.DLL + 0x5824 (0x77e15824)  
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 303] 
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1301] 
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1628] 
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1646] 
	 WinMainCRTStartup()  
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)   
 
     (2560419)	Comments: downloading a new skin for 9.8 from skin web site
     (2559069)	Comments: Changing theme back to modern
     (2558596)	Comments: while downloading(installing) theme  i  switched current theme
     (2547614)	URL: www.popcap.com
     (2547614)	Comments: I tried to switch skins and it crashed on me.
     (2547394)	Comments: Selecting another theme from the view menu
     (2545419)	URL: http://commcenter.net2phone.com/GLPPublish.asp?idpage=startdl
     (2545238)	URL: http://commcenter.net2phone.com/GLPPublish.asp?idpage=startdl
     (2536542)	Comments: switching themes
     (2531811)	URL: google.com
     (2531811)	Comments: switched theme from LCARS-Startrek to Modern. Crash. Was switching
through all the themes on xul before that. Eskimo may have left some widgets
lying around?
     (2522986)	Comments: I was switching themes and it nuked
     (2519096)	Comments: Installing a new skin in Mozilla 0.9.8 from xulplanet.com


MozillaTrunk:

nsCSSFrameConstructor::ContentStatesChanged   23 
BBID range: 2198049 - 2562958
Min/Max Seconds since last crash: 13 - 116454
Min/Max Runtime: 218 - 116454
Crash data range: 2002-01-27 to 2002-02-05
Build ID range: 2002012711 to 2002020515
Keyword List : theme(5), 
Stack Trace: 

	 nsCSSFrameConstructor::ContentStatesChanged
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 10054]
	 StyleSetImpl::ContentStatesChanged
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1482]
	 PresShell::ContentStatesChanged
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5101]
	 nsXULDocument::ContentStatesChanged
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp  line 1941]
	 nsEventStateManager::SetContentState
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 3447]
	 nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 1539]
	 PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 6009]
	 PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5911]
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 390]
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 347]
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 347]
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 347]
	 nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1900]
	 HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 83]
	 nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 854]
	 nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 871]
	 nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4537]
	 ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4787]
	 nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 3463]
	 nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 1116]
	 USER32.dll + 0x3a5f (0x77d43a5f)
	 USER32.dll + 0x3b2e (0x77d43b2e)
	 USER32.dll + 0x3d6a (0x77d43d6a)
	 USER32.dll + 0x41fd (0x77d441fd)
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 308]
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1301]
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1628]
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1646]
	 WinMainCRTStartup()
	 kernel32.dll + 0x1eb69 (0x77e7eb69)
 
 	Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp
line : 10054
     (2547408)	Comments: while change theme
     (2508310)	Comments: applying theme
     (2411291)	Comments: changed themes from startrek 0.9.6 to modern 0.9.7
     (2404271)	Comments: installing themes
     (2402051)	Comments: Selecting another installed Theme  in the View-Menu.Theme
LittleMozilla Version 0.9.6
     (2198259)	Comments: Attempting to apply the skin Fog City
     (2198049)	Comments: Trying to switch skins from LCARTStrek to Classic.
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash

Comment 1

16 years ago
dupe of 119029??

Comment 2

16 years ago
nominating topcrash bugs for nsbeta1. 
Keywords: nsbeta1

Comment 3

16 years ago
nsbeta1+ per ADT triage team.  We plan to revert back to requiring a restart on
theme switch, which *may* fix this bug.  In any case, we need to fix this for MachV.
Keywords: nsbeta1 → nsbeta1+

Comment 4

16 years ago
Here is the latest Talkback data on this stack signature:

Min/Max Seconds since last crash: 30 - 5273
Min/Max Runtime: 30 - 5273
Crash data range: 2002-02-24 to 2002-02-26
Build ID range: 2002022311 to 2002022509
Stack Trace: 

	 nsCSSFrameConstructor::ContentStatesChanged
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 10096]
	 StyleSetImpl::ContentStatesChanged
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1482]
	 PresShell::ContentStatesChanged
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5104]
	 nsXULDocument::ContentStatesChanged
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp  line 1942]
	 nsEventStateManager::SetContentState
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 3571]
	 nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 1663]
	 PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 6026]
	 PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5928]
	 nsViewManager::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 2043]
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 306]
	 nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1863]
	 HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 83]
	 nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 860]
	 nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 877]
	 nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4619]
	 ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4869]
	 nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 3544]
	 nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 1122]
	 USER32.DLL + 0x2e98 (0x77e12e98)
	 USER32.DLL + 0x30e0 (0x77e130e0)
	 USER32.DLL + 0x5824 (0x77e15824)
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 308]
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1301]
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1628]
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1646]
	 WinMainCRTStartup()
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)
 
 	Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp
line : 10096


COMMENTS/URLs

     (3305461)	URL: www.omropfryslan.nl
     (3305461)	Comments: switching to theme "Lopbury Flat"

(Reporter)

Comment 5

16 years ago
Jan...where did you get that data from.  Does it reflect MozillaTrunk data or is
it from a recent milestone?  I'm guessing Trunk...so adding qawanted to see if
we can get this reproduced.
Keywords: qawanted

Comment 6

16 years ago
This bug does not belong to Ben.
-> hyatt
Assignee: ben → hyatt
(Reporter)

Updated

16 years ago
Depends on: 127784
(Reporter)

Comment 8

16 years ago
Updating summary with M099 since this is a topcrasher for Mozilla 0.9.9.  Here
are all the user comments we have so far.  I'm still trying to reproduce this
particular themes switch crash.

(3974428)
Comments: Trying out different Themes.  When I tried to switch from one to the
other - it crashed.
     (3971384)	Comments: Switching from the LCARStrek theme to the Classic theme (thought
it seems happen when switching from LCARStrek to any other theme).  This is on
WinXP... you can download the LCARStrek by going to the "View" > "Apply Theme" >
"Get New Themes".  
     (3970965)	Comments: When you switch to the LCARStrek theme and then switch to another
one it crashes.  Occasionally switching to the LCARStrek theme crashes but
EVERYTIME I switch off it (assuming I could load it) crashes.
     (3970868)	Comments: I was trying to restore the "classic" skin
     (3968480)	Comments: changing themes
     (3964716)	Comments: I was changing the Theme and the LCARS star Trek theme was so ugly
I think it broke my browser.  At least that's what I think.
     (3964641)	URL: http://www.plethoratech.com/product/
     (3964641)	Comments: I had just downloaded v0.9.9 and then all of the available themes.
I was going through changing the theme to all of the themes I downloaded to see
what they look like. It crashed when I changed from LCARStrek to LittleMozilla.
I also had an instance of
     (3964641)	Comments:  the mail client open at the time.
     (3961451)	URL: http://members.home.net/hteller/digipan/download.htm
     (3961451)	Comments: Changed theme to "LittleMozilla"
     (3957461)	Comments: i had just tried to switch from a star trek theme i downloaded
back to the modern theme.  i guess it just didn't like me :)
     (3955167)	Comments: I was just switching the themes and tried all the ones I had
downloaded and it crashed when I switched back to the original theme that I was
using.
     (3954177)	Comments: I was selecting a new theme - LittleMozilla.After restarting
Mozilla  the theme had been applied.I had previously downloaded and applied
several (3 or 4) themes to try them out.
     (3945826)	Comments: I noticed the 'classic' buttons were not displaying correctly so I
changed the theme to modern  then I selected the get new themes selection.I had
just installed the 'LCARStrek' theme  saw how hideous it was  and changed the
theme to modern.
     (3939257)	Comments: Selecting "startrek" skin from View menu - crashed1 or 2 seconds
after mouse click. Happened several times.Once on a different skin (don't
remember which).Maybe same event as my previous report an hour ago.Microsoft
error-report box "mozilla.exe
     (3939257)	Comments:  has encountereda problem" etc. always appeared before yours. All
7 newskins were downloaded within the hour.
     (3938544)	Comments: changed skin
     (3930407)	Comments: Changing Themes
Summary: Trunk M098 crash switching themes [@ nsCSSFrameConstructor::ContentStatesChanged] → Trunk M099 crash switching themes [@ nsCSSFrameConstructor::ContentStatesChanged]

Comment 9

16 years ago
ADT3 per ADT/Nav triage.
Blocks: 108795
Whiteboard: [ADT3]

Comment 10

16 years ago
Marking as topcrash+ since this is easily reproducible.

- apply classic theme
- apply modern theme
- crash
Keywords: topcrash → topcrash+
I'd be interested in seeing the registers, disassembly, and stack for a single
incident (with the build date, since otherwise the stack is useless) for this crash.

Comment 12

16 years ago
Created attachment 74588 [details]
Stack, comment, register and dump from incident 3971384

David, here is the info you wanted for a single incident (#3971384 from comment
#8 above). I chose it simply because is seems to reflect other crashes
mentioned also. If you would like to see others I can supply them Monday.

Comment 13

16 years ago
removing 108795 as a blockee, since there is no indication this has anything to
do with QuickLaunch.
No longer blocks: 108795
(Reporter)

Comment 14

16 years ago
Dependant bug 127784 has been verified fixed...dynamic theme switching has been
disabled.  Since Talkback shows this last crashed on the Trunk on 3/14, I'm
going to mark this worksforme.  We shouldn't see this crash anymore with dynamic
theme switching turned off. 

If anyone is able to reproduce this crash with a recent Trunk build or finds a
good reason to reopen it, please do.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

16 years ago
verified wfm.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
Crash Signature: [@ nsCSSFrameConstructor::ContentStatesChanged]
You need to log in before you can comment on or make changes to this bug.