5% Linux 64/Win8 damp/tp5o regression on Mozilla-Inbound-Non-PGO on January 14, 2016 from push e6f00eab30ae

RESOLVED DUPLICATE of bug 1239834

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1239834
3 years ago
2 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

(Blocks: 1 bug, {perf, regression})

Trunk
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

3 years ago
Talos has detected a Firefox performance regression from your commit e6f00eab30ae7f2611a13d22b512fd7a39df09e7 in bug 1236104.  We need you to address this regression.

This is a list of all known regressions and improvements related to your bug:
http://alertmanager.allizom.org:8080/alerts.html?rev=e6f00eab30ae7f2611a13d22b512fd7a39df09e7&showAll=1

On the page above you can see Talos alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test, please see:
https://wiki.mozilla.org/Buildbot/Talos/Tests#DAMP
https://wiki.mozilla.org/Buildbot/Talos/Tests#tp5

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p linux64,win64 -u none -t g2,tp5o  # add "mozharness: --spsProfile" to generate profile data

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.org/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e <path>/firefox -a damp,tp5o

Making a decision:
As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Tuesday, or the offending patch will be backed out! ***

Our wiki page outlines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
(Reporter)

Updated

3 years ago
Summary: 5% Linux 64/Win8 damp/tp5o/tp5o/tp5o regression on Mozilla-Inbound-Non-PGO on January 14, 2016 from push e6f00eab30ae → 5% Linux 64/Win8 damp/tp5o regression on Mozilla-Inbound-Non-PGO on January 14, 2016 from push e6f00eab30ae
(Reporter)

Comment 1

3 years ago
a compare chooser view:
https://treeherder.allizom.org/perf.html#/compare?originalProject=mozilla-inbound&originalRevision=ab3c6ba63c89&newProject=mozilla-inbound&newRevision=e6f00eab30ae&framework=1

the ones of concern are:
ts_paint e10s: win7, win8
tp5o xres e10s: linux64
tp5o: all platforms
tp5o e10s: all platforms
tp5o private bytes: winxp, win7, linux64
tp5o private bytes e10s: winxp, win7, linux64
tp5o main_rss: all platforms
tp5o % processor time: winxp, win7
tcanvasmark e10s: win*
tcanvasmark: winxp
damp e10s: win7, win8, osx 10
damp: win7, win8, osx10, linux64


:yury, I understand you were looking into this already- if there is another bug to track this please let us know, otherwise, ask for help and keep us up to date
Flags: needinfo?(ydelendik)
Is it a dup of bug 1239834?
Flags: needinfo?(ydelendik)
(Reporter)

Comment 3

3 years ago
yes it is, sorry
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239834
Clearing status flag on dup.
status-firefox46: affected → ---
You need to log in before you can comment on or make changes to this bug.