{css1} weaker rule in linked stylesheet is winning

VERIFIED FIXED in M11

Status

()

P2
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: peterl-retired)

Tracking

({css1})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] (py8ieh:fodder for the importtest...), URL)

Attachments

(2 attachments)

DESCRIPTION:  The (red) left margin of the paragraph in the above URL disappears
after the page finishes loading.  It flashes its correct appearance first.

STEPS TO REPRODUCE:  Load above URL.

ACTUAL RESULTS:  Paragraph is black text on gray background, surrounded by gray
padding,  black border, and then surrounded by red on top, bottom, and right
(top and bottom thicker than right), BUT NOT LEFT.  The expected results do
appear quickly while the page is loading.

EXPECTED RESULTS:  Paragraph should be black text on gray background, surrounded
by gray padding, black border, and red on *ALL 4* sides.  (The red should be
thicker on the top and bottom than the right and left.)

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-08-20-13-M10

ADDITIONAL INFORMATION:
Are you trying to do carried out side-margins or something?
I'm seeing the same problem in the second test paragraph in
http://www.editions-eyrolles.com/livres/glazman/Tests/boites/boites2.htm .
From the look of this, it could actually be style system, not layout.  Something
to do with margin-left vs. margin???  I'm also seeing it on
http://www.editions-eyrolles.com/livres/glazman/Tests/boites/boites3.htm

Updated

19 years ago
Assignee: troy → peterl
Component: Layout → Style System

Comment 4

19 years ago
Changing to style system since that's what it looks like
Summary: {inc}margin-left disappears → weaker rule in linked stylesheet is winning
Whiteboard: [TESTCASE]
What's happening here is that a rule in the linked stylesheet with lower
specificity is winning.  This shouldn't happen.  Perhaps the embedded and linked
stylesheets are somehow being treated as different levels of the cascade?

Retitling bug.  Marking [TESTCASE].  In the attached testcase, the text should
be green, but it's red.
Created attachment 1369 [details]
linked CSS file used by testcase
OS: Linux → All
Hardware: PC → All
ALSO DOES NOT WORK CORRECTLY ON:
 * Windows, apprunner, 1999-08-24-09-M10

Marking All/All.
Summary: weaker rule in linked stylesheet is winning → {css1} weaker rule in linked stylesheet is winning
Whiteboard: [TESTCASE] → [TESTCASE] (py8ieh:fodder for the importtest...)
[Just adding two radars...]
(Assignee)

Comment 10

19 years ago
Moving non-beta 1 items to M15
This is also tested in part 4 of the folowing EvilTests test:
   http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/cascade/easy.html

This seems like quite a fundamental problem. Is it a recent regression?
(Assignee)

Comment 12

19 years ago
Not a regression. It was implemented this way because that's the way I
interpreted the spec.

Comment 13

19 years ago
Hyatt says this bug has cost too many man hours; he and cmanske just spent two
each chasing false leads before realizing that someone had checked in some bad
editor css, which was having unintended effects on more specific rules.

This shouldn't be M15 -- can it be fixed ASAP, even before the content sink
high colonic?  Can someone else help fix it?

/be

Updated

19 years ago
QA Contact: petersen → chrisd
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15 → M10

Updated

19 years ago
Target Milestone: M10 → M11

Comment 14

19 years ago
Moving to M11...M10 is out the door.

Updated

19 years ago
Priority: P3 → P2
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
Testing using 10/21 app on Win, Mac and Linux with original test case, verified
bug fixed. Red margin displays on page load.
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.