If one of the bug suggestions is a duplicate, can we show the bug id of the bug it is a duplicate of?

RESOLVED WONTFIX

Status

Tree Management
Treeherder
RESOLVED WONTFIX
2 years ago
8 months ago

People

(Reporter: KWierso, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
When I select a failed job and one of the bug suggestions for that failure is crossed out because it is resolved - duplicate, it would be nice to show what bug it is a duplicate of in the tooltip (instead of just "duplicate").

I believe that number is surfaced in the api as "dupe_of". If dupe_of is not null, it should be the id of the bug that this bug was duped to.
I think Treeherder shouldn't try to fix up bad input data. The duped-to bug should be updated to have the correct summary / keyword moved over etc.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.