Flash 20.0.0.285 (beta) sometimes crashes when HWA is enabled in Flash settings

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

(5 keywords)

45 Branch
All
Windows
crash, crashreportid, flashplayer, regression, thirdparty
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 unaffected, firefox45- fixed, firefox46- fixed)

Details

(Whiteboard: [fixed in Flash 20.0.0.286 (stable)], crash signature)

(Reporter)

Description

3 years ago
STR

1. Use current 64 bit Nightly.  I haven't tested on 32 bit Nightly.

2. Install the latest Flash beta at https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player.exe

3. Insure HWA is enabled in the Flash settings.

4. Play anything Flash.

Crash report at https://crash-stats.mozilla.com/report/index/c5f7b849-3c8d-48f8-af9e-adf402160114#allthreads

The current stable version of Flash works fine v20.0.0.267.
Fx44 beta 9 also works fine with the Flash beta.
(Reporter)

Updated

3 years ago
Component: General → Graphics
Keywords: flashplayer
Product: Firefox → Core
Thanks for reporting this, Gary. Based on your comment above this probably started in the Firefox 45-46 timeframe. Can you please use mozregression to determine in which Firefox version this started?
http://mozilla.github.io/mozregression/install.html
Flags: needinfo?(garyshap)
Might also be worth checking if this occurs with multi-process turned off in Nightly. That would be one major difference between Beta and Nightly right now.
[Tracking Requested - why for this release]: nominating to track so this gets on Release Management's radar. I'm not sure if we have any contacts at Adobe but they should be apprised of this bug. It could be a shared regression in Flash and Firefox.
tracking-firefox46: --- → ?
(Reporter)

Comment 4

3 years ago
I'm having problems with running mozregression.  However, here's the regression range from /pub/firefox/tinderbox-builds/mozilla-inbound-win64-pgo/

Good
20151210103013
https://hg.mozilla.org/integration/mozilla-inbound/rev/43b88627500d84f39850c13cfe8ec964caa40ca7

Bad
20151210133032
https://hg.mozilla.org/integration/mozilla-inbound/rev/7bedc0cbb9350c2cdf0cf404f292d9abc576d85f
Flags: needinfo?(garyshap)
(Reporter)

Comment 5

3 years ago
Just wanted to add that if I turn off HWA in Fx Options Flash works even though HWA in Flash settings says it's enabled.  I assume that Fx's HWA overrides Flash's HWA?
(Reporter)

Comment 6

3 years ago
Hoping I'm not confusing things but there is another problem with Flash.  See my post at https://bugzilla.mozilla.org/show_bug.cgi?id=1210050.  This problem goes way back.
(Reporter)

Comment 8

3 years ago
It look like this patch is the problem:
https://bugzilla.mozilla.org/show_bug.cgi?id=1229961

Part 2 of the patch did this:
-pref("dom.ipc.plugins.asyncdrawing.enabled", false);
+pref("dom.ipc.plugins.asyncdrawing.enabled", true);

I set this pref to false and the Flash beta works fine.  Still have the scrolling problem mentioned above.

Updated

3 years ago
Blocks: 1229961
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ npswf64_20_0_0_285.dll@0x2cd49c ] [@ npswf32_20_0_0_285.dll@0x22119e ] [@ npswf32_20_0_0_285.dll@0x38aead ]
status-firefox43: --- → unaffected
status-firefox44: --- → unaffected
status-firefox45: --- → affected
status-firefox46: --- → affected
tracking-firefox45: --- → ?
Component: Graphics → Plug-ins
Ever confirmed: true
Hardware: x86_64 → All
Summary: Flash betas crash on Nightly when HWA is enabled in Flash settings. → Flash beta always crash on Nightly when HWA is enabled in Firefox and Flash settings
Version: 46 Branch → 45 Branch
(Reporter)

Updated

3 years ago
Summary: Flash beta always crash on Nightly when HWA is enabled in Firefox and Flash settings → Flash beta always crash on Nightly when HWA is enabled in Firefox or Flash settings
(Reporter)

Comment 9

3 years ago
Seems to me the problem is not with HWA but with whatever processing the pref dom.ipc.plugins.asyncdrawing.enabled = true does.  Turning off HWA is just a work around.

Btw.. I opened up a bug report at Adobe...  https://bugbase.adobe.com/index.cfm?event=bug&id=4107657

The priority was changed to very high, not by me.

Comment 10

3 years ago
See also:
https://bugzilla.mozilla.org/show_bug.cgi?id=1232191

I have already opened a bug report at Adobe (December 13, 2015):
https://bugbase.adobe.com/index.cfm?event=bug&id=4099489

Adobe Flash Player beta forum:
https://forums.adobe.com/thread/2060066
(Reporter)

Comment 11

3 years ago
(In reply to MrX1980 from comment #10)
> See also:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1232191
> 
> I have already opened a bug report at Adobe (December 13, 2015):
> https://bugbase.adobe.com/index.cfm?event=bug&id=4099489
> 
> Adobe Flash Player beta forum:
> https://forums.adobe.com/thread/2060066

Your bug report states that you have to go into fullscreen mode to get the crash.  Is this still true for you?  I get the crash no matter if it's fullscreen or not.
(Reporter)

Comment 12

3 years ago
I get the feeling that Adobe doesn't act on it's bug reports in a timely manner.

Comment 13

3 years ago
I tested some more websites. Some video contents are only crashing if I click on the fullscreen button. Some websites like bbc.com or yahoo.com are working fine. Currently Dailymotion is the only one, where the video content directly crashes.
Some websites with flash games are also crashing. For example: flash-games.net or miniclip.com/games/
All with the same crash signatures (32-bit and 64-bit).
Blocks: 1217665
status-firefox43: unaffected → ---
Keywords: crash, crashreportid, regression, thirdparty
OS: Windows 10 → Windows
See Also: → bug 1232191
Summary: Flash beta always crash on Nightly when HWA is enabled in Firefox or Flash settings → Flash 20.0.0.285 (beta) always crash in fullscreen when HWA is enabled in Firefox or Flash settings
Crash Signature: [@ npswf64_20_0_0_285.dll@0x2cd49c ] [@ npswf32_20_0_0_285.dll@0x22119e ] [@ npswf32_20_0_0_285.dll@0x38aead ] → [@ npswf64_20_0_0_285.dll@0x2cd49c ] [@ npswf64_20_0_0_285.dll@0x2cd5a2 ] [@ npswf32_20_0_0_285.dll@0x22119e ] [@ npswf32_20_0_0_285.dll@0x38aead ]
(Reporter)

Comment 14

3 years ago
It isn't always in fullscreen mode that I crash.  Also, it's all of the Flash betas that crash.  20.0.0.267 was the last beta that didn't crash and that is now the stable version.  There are 2 or 3 beta versions now.

Go to www.gasbuddy.com and see the flash video crash even without playing it.  I just get a black video box but a crash report is produced.
(Reporter)

Comment 15

3 years ago
Just want to add that the videos at weather.com also crash without going fullscreen.  It's true that not all flash videos crash.  Those at cnn and msn play fine.
(Reporter)

Updated

3 years ago
Summary: Flash 20.0.0.285 (beta) always crash in fullscreen when HWA is enabled in Firefox or Flash settings → Flash 20.0.0.285 (current beta) sometimes crashes when HWA is enabled in Flash settings
(Reporter)

Comment 16

3 years ago
Let's be clear on some things.

1. Enabling HWA in Fx automatically turns on HWA in Flash.  But you can still disable HWA in Flash and enable it in Fx. Of course you need to find a flash video that doesn't crash to do this. 

2. What about my findings regarding dom.ipc.plugins.asyncdrawing.enabled = true?  When this was turned on the crashes started.  Turning off HWA in Flash or disabling the pref in Fx are comparable work around's.
This would seem to indicate this as an IPC bug. Flagging :dvander to look in to this.
Component: Plug-ins → IPC
Flags: needinfo?(dvander)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #17)
> This would seem to indicate this as an IPC bug.

To be fair this could also be an IPC incompatibility issue with the Flash Beta.
Tracking as it is potentially an important crash.
Chris, could you help here? Thanks
tracking-firefox45: ? → +
tracking-firefox46: ? → +
Flags: needinfo?(cpeterson)
(Reporter)

Comment 20

3 years ago
Adobe just released Beta v20.0.0.286 and that appears to have fixed the crashes.
tracking-firefox45: + → ?
tracking-firefox46: + → ?
(Reporter)

Comment 21

3 years ago
Actually 286 isn't a beta. It's the newest stable release.  Guess we can close this then?
OK, untracking as it is probably fixed.
status-firefox45: affected → fixed
status-firefox46: affected → fixed
tracking-firefox45: ? → -
tracking-firefox46: ? → -
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Summary: Flash 20.0.0.285 (current beta) sometimes crashes when HWA is enabled in Flash settings → Flash 20.0.0.285 (beta) sometimes crashes when HWA is enabled in Flash settings
Whiteboard: [fixed in Flash 20.0.0.286 (stable)]
Flags: needinfo?(cpeterson)
(In reply to Gary [:streetwolf] from comment #21)
> Actually 286 isn't a beta. It's the newest stable release.  Guess we can
> close this then?

Well, not necessarily. This might be something unique about the Beta versions of Flash. It'd be worth checking the next Beta version just to confirm.

Comment 24

3 years ago
Still the same problem (but different crash signatures) with Flash Player 20.0.0.294 beta
https://crash-stats.mozilla.com/report/index/cb60c5f5-f82e-407d-9dfd-8049c2160120
https://crash-stats.mozilla.com/report/index/92277c54-9f09-448e-94ec-3016a2160120

Could it be, that different compiling options between the final and beta version can cause this?
(In reply to MrX1980 from comment #24)
> Still the same problem (but different crash signatures) with Flash Player
> 20.0.0.294 beta
> https://crash-stats.mozilla.com/report/index/cb60c5f5-f82e-407d-9dfd-
> 8049c2160120
> https://crash-stats.mozilla.com/report/index/92277c54-9f09-448e-94ec-
> 3016a2160120
> 
> Could it be, that different compiling options between the final and beta
> version can cause this?

It's possible but only Adobe would know for sure. Changing resolution to INVALID as this doesn't appear to be our bug.
Resolution: FIXED → INVALID
Flags: needinfo?(dvander)
You need to log in before you can comment on or make changes to this bug.