Login into www.finnkino.fi doesn't work in FF45 nor 46

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: smaug, Unassigned)

Tracking

36 Branch
Points:
---

Firefox Tracking Flags

(firefox44 unaffected, firefox45+ fixed, firefox46+ fixed)

Details

I can't log into www.finnkino.fi using aurora (45) or nightly (46). The password field just doesn't accept any input. Focus disappears immediately.
This did work still a week ago. So either something has changed in the site so that it doesn't work with 45/46 or we've regressed something recently.

I'll try find regression range later.


[Tracking Requested - why for this release]: www.finnkino.fi is the movie theater site in Finland. Tons of users.
This is hard to figure out. The last Aurora/44 fails and the first Beta/44 works.
So some API which is currently activated only in Nightly and Aurora causes the login to fail, or 
more precisely one can't focus the password field ( 'salasana' close to the top of the page ).
Sounds like a regression, tracking for 45 and 46.
tracking-firefox45: ? → +
tracking-firefox46: ? → +
Hi reporter,

I haven't managed to reproduce this issue on the latest release(44.0) nor latest Nightly(47.0a1).

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160127030236

I've also tested on Aurora 44, Aurora 45 and Nightly 46, but I was able to fill in the password field and log on the website you provided. Is not possible for me to perform a regression since I'm unable to reproduce the bug on any specified build.

Can you please try to reproduce this on the latest release(44.0) and latest Nightly(47.0a1) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Paul.
Flags: needinfo?(bugs)
ok, looks like they have now changed their site, since the bug was there still last weekend, but can't reproduce it anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bugs)
Keywords: regression, regressionwindow-wanted
Resolution: --- → WORKSFORME
Hi reporter,

I'm happy to hear that you no longer encounter this issue. Please feel free to file a new bug if you encounter one.

Thanks,
Paul.
Marking fixed.
status-firefox45: affected → fixed
status-firefox46: affected → fixed

Comment 7

2 years ago
symptoms sound a bit like https://bugzilla.mozilla.org/show_bug.cgi?id=1244505 but hard to say now that the content is gone.

the patch for https://bugzilla.mozilla.org/show_bug.cgi?id=1233784 that caused the cookie regression that resulted in people being left without login auth cookies working right seems to have landed on beta 2015-12-22 13:38:45 PST.  would that landing date explain the "worked in 44 beta 1, but not the last 44 beta?"
You need to log in before you can comment on or make changes to this bug.